Bug 2009063 - Workstation edition does not notify the user of available updates
Summary: Workstation edition does not notify the user of available updates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F35FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-09-29 19:44 UTC by Chris Murphy
Modified: 2021-11-01 14:55 UTC (History)
9 users (show)

Fixed In Version: gnome-software-41.0-2.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-06 15:57:27 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
journal log (293.49 KB, text/plain)
2021-09-29 19:48 UTC, Chris Murphy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-software merge_requests 1008 0 None None None 2021-09-30 14:56:27 UTC

Description Chris Murphy 2021-09-29 19:44:19 UTC
Description of problem:

Fedora Workstation 35, upgraded from 34, is not notifying me of downloaded RPMs ready for updating. But it does notify me that two flatpaks have been updated.


Version-Release number of selected component (if applicable):
PackageKit-1.2.4-2.fc35.x86_64
gnome-software-41.0-1.fc35.x86_64


How reproducible:
uncertain

Steps to Reproduce:
1. also uncertain
2.
3.

Actual results:

No upgrade notification


Expected results:

After a week or two (?) I expect there should be a notification to update the system when there are available RPM updates.


Additional info:

Comment 1 Fedora Blocker Bugs Application 2021-09-29 19:47:23 UTC
Proposed as a Blocker for 35-final by Fedora user chrismurphy using the blocker tracking app because:

 Release-blocking desktops must notify the user of available updates, but must not do so when running as a live image. 
https://fedoraproject.org/wiki/Fedora_35_Final_Release_Criteria#Update_notification

Comment 2 Chris Murphy 2021-09-29 19:48:35 UTC
Created attachment 1827494 [details]
journal log

Comment 3 Michael Catanzaro 2021-09-29 20:14:13 UTC
I know you're coming here from https://pagure.io/fedora-workstation/issue/107#comment-753794, but for the purposes of keeping everything in this bug, let's confirm that it's been more than two weeks since your last update. E.g. yesterday I ran:

$ gsettings get org.gnome.software install-timesamp
1631660863

Then I fed that into DuckDuckGo to convert from Unix time to human-readable time: https://duckduckgo.com/?q=1631660863+unix+time&t=epiphany&ia=answer

And it tells me my last update was installed on "Tue Sep 14 18:07:43 2021 -0500." When was your last update?

Comment 4 Chris Murphy 2021-09-29 20:25:54 UTC
$ gsettings get org.gnome.software install-timestamp
int64 1614618019

Translates to: GMT: Monday, March 1, 2021 5:00:19 PM
That would be about the time of the last gnome-software update (I normally do dnf updates).

Comment 5 Chris Murphy 2021-09-29 20:44:42 UTC
One of these changes, followed by a reboot and login, results in the update notification appearing:
 gsettings set org.gnome.software check-timestamp "int64 1630458000"
 gsettings set org.gnome.software online-updates-timestamp "int64 1630458000"
 gsettings set org.gnome.software update-notification-timestamp "int64 1630458000"

Comment 6 Chris Murphy 2021-09-29 20:53:20 UTC
1630458000 is Sep 1 2021

Comment 7 Chris Murphy 2021-09-30 13:01:32 UTC
Last night I did a shutdown, and too quickly acknowledged the dialog which had the 'install pending updates' option checked. (Nitpick, I didn't get a shutdown but a restart instead, which I force powered off at GRUB. When asking for a shutdown, I shouldn't get restart just because there pending updates. Bug 2009353) This morning at cold boot time, the system successfully installed pending updates.

Comment 8 Milan Crha 2021-09-30 14:56:27 UTC
(In reply to Michael Catanzaro from comment #3)
> Then I fed that into DuckDuckGo to convert from Unix time to human-readable

If you do not want to use a website for it, then:

   $ date --date=`@1631660863`

does a similar job.

In any case, I found the flaw in the code and proposed a patch upstream [1]. Let's wait for the review of that change.

[1] https://gitlab.gnome.org/GNOME/gnome-software/-/merge_requests/1008

Comment 9 Adam Williamson 2021-10-04 15:30:51 UTC
-4 blocker, +5 FE in https://pagure.io/fedora-qa/blocker-review/issue/485 - marking as such.

Comment 10 Fedora Update System 2021-10-04 16:08:09 UTC
FEDORA-2021-ec19af5827 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-ec19af5827

Comment 11 Fedora Update System 2021-10-05 15:17:44 UTC
FEDORA-2021-ec19af5827 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-ec19af5827`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-ec19af5827

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Kamil Páral 2021-10-06 14:51:14 UTC
(In reply to Fedora Update System from comment #10)
> FEDORA-2021-ec19af5827 has been submitted as an update to Fedora 35.
> https://bodhi.fedoraproject.org/updates/FEDORA-2021-ec19af5827

I can make the notifications appear with the above update when following https://fedoraproject.org/wiki/QA:Testcase_desktop_update_notification (I edited the wiki and advised to set all possibly relevant timestamp keys, which is probably overkill, but it works).

Comment 13 Fedora Update System 2021-10-06 15:57:27 UTC
FEDORA-2021-ec19af5827 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.