Bug 2009094 - Need ACM Managed Cluster Info metric enabled for OCP monitoring telemetry
Summary: Need ACM Managed Cluster Info metric enabled for OCP monitoring telemetry
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Telemeter
Version: 4.6.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.z
Assignee: Nobody
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1956565
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-29 23:20 UTC by Joydeep Banerjee
Modified: 2021-11-03 21:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-03 21:01:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 1408 0 None open Bug 2009094: manifest allowlist: add acm_managed_cluster_info in 4.6 2021-09-30 14:47:21 UTC
Red Hat Product Errata RHBA-2021:4009 0 None None None 2021-11-03 21:01:46 UTC

Description Joydeep Banerjee 2021-09-29 23:20:12 UTC
Description of problem:


This metric is already merged in OCP 4.8 using Bug #1945677

This issue is not for a bug.  To enable a metric from ACM in OCP 4.7 - acm_managed_cluster_info for OCP monitoring telemetry, we need to open a PR against the openshift/cluster-monitoring-operator manifest allowlist.  The monitoring team's process, though, requires that the PR be associated with a Bugzilla issue number.  This metric provides Subscription watch and other information for the managed clusters for an ACM Hub cluster.

Detailed description of this metric is here: https://docs.google.com/document/d/1uvCk73lWQ-LGqFNla6IMRuur5Fj6q59Y2UMpGK5AaWs/edit?usp=sharing


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Junqi Zhao 2021-10-14 03:17:28 UTC
waiting for the fix merged to payload

Comment 4 Junqi Zhao 2021-10-14 13:08:29 UTC
tested with 4.6.0-0.nightly-2021-10-14-030206, acm_managed_cluster_info is in telemetry-config configmap, and it is already added to telemeter server
# oc -n openshift-monitoring get cm telemetry-config -o jsonpath="{.data.metrics\.yaml}" | grep {__name__= | grep acm_managed_cluster_info
- '{__name__="acm_managed_cluster_info"}'

Comment 7 errata-xmlrpc 2021-11-03 21:01:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.49 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4009


Note You need to log in before you can comment on or make changes to this bug.