Bug 2009189 - Annotations value not updating in workload sidebar after changing annotations value
Summary: Annotations value not updating in workload sidebar after changing annotations...
Keywords:
Status: CLOSED DUPLICATE of bug 2064256
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.9
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.11.0
Assignee: Christoph Jerolimov
QA Contact: spathak@redhat.com
Rishu Mehra
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-30 07:05 UTC by spathak@redhat.com
Modified: 2022-05-23 10:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Sidebar does not receive updated resource on updating workload Consequence: Values in sidebar does not update on updating them in the workload from the sidebar or elsewhere Workaround (if any): close and reopen the sidebar to get updated values. Result: make topology sidebar observe changes to workload and reflect updated values in the workload.
Clone Of:
Environment:
Last Closed: 2022-05-23 10:05:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 10573 0 None open [WIP] Bug 2009189: fix annotations on updating deployment 2021-11-29 12:44:34 UTC
Github openshift console pull 11039 0 None open Bug 2044454: update resources on change and remove renderNull Callback 2022-03-02 10:41:48 UTC
Github openshift console pull 11420 0 None open Bug 2064256: Fix topology sidebar update issues 2022-05-03 11:05:35 UTC

Description spathak@redhat.com 2021-09-30 07:05:30 UTC
Description of problem:
Changing annotations value in workload sidebar do not reflect on sidebar automatically

Version-Release number of selected component (if applicable):
4.9.0-0.nightly-2021-09-09-145014

How reproducible:


Steps to Reproduce:
1. Create a workload(eg: Knative service, deployment)
2. Open sidebar select Details tab
3. Add an annotation 

Actual results:
Annotation number in details tab in workload sidebar remains the same

Expected results:
Annotation number in details tab in workload sidebar should automatically be updated

Additional info:
Check out the video "Annotation number fails to update" for more info

Comment 7 spathak@redhat.com 2022-01-31 09:05:25 UTC
Verified on build version: 4.10.0-0.nightly-2022-01-31-012936
Browser: Google Chrome 97

Comment 9 Christoph Jerolimov 2022-02-10 09:47:26 UTC
Reopen this issue as we revert this with PR https://github.com/openshift/console/pull/11002, to fix a new introduced issue https://bugzilla.redhat.com/show_bug.cgi?id=2049483

Comment 12 Christoph Jerolimov 2022-05-23 10:05:33 UTC
This issue is solved with PR https://github.com/openshift/console/pull/11420 in 4.11.

As all these issues have the same root cause we mark this as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=2064256

We will backport this back to 4.8.

*** This bug has been marked as a duplicate of bug 2064256 ***


Note You need to log in before you can comment on or make changes to this bug.