Bug 2009224 - Regular user cannot restore VM snapshot
Summary: Regular user cannot restore VM snapshot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.8
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.8.z
Assignee: Aviv Turgeman
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On: 1985164
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-09-30 08:25 UTC by Guohua Ouyang
Modified: 2021-11-23 11:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1985164
Environment:
Last Closed: 2021-11-23 11:33:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 10436 0 None open [release-4.8]Bug 2009224: Regular user cannot restore VM snapshot 2021-11-11 07:27:57 UTC
Red Hat Product Errata RHBA-2021:4716 0 None None None 2021-11-23 11:33:50 UTC

Description Guohua Ouyang 2021-09-30 08:25:45 UTC
+++ This bug was initially created as a clone of Bug #1985164 +++

Description of problem:
While restore a snapshot it meets an error:
Danger alert:An error occurred
virtualmachinerestores.snapshot.kubevirt.io "rhel6-itchy-quail-2021-7-23-restore-c6f9mc" is forbidden: cannot set blockOwnerDeletion if an ownerReference refers to a resource you can't set finalizers on: , <nil>

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Login with a regular user
2. Create a VM which can take snapshot
3. Take a snapshot and then try to restore the snapshot

Actual results:


Expected results:


Additional info:

--- Additional comment from OpenShift Automated Release Tooling on 2021-08-04 13:36:12 CST ---

Elliott changed bug status from MODIFIED to ON_QA.

--- Additional comment from Guohua Ouyang on 2021-08-09 12:42:26 CST ---

verified on master

--- Additional comment from errata-xmlrpc on 2021-09-07 16:58:25 CST ---

This bug has been added to advisory RHEA-2021:81213 by OpenShift Release Team Bot (ocp-build/buildvm.openshift.eng.bos.redhat.com)

--- Additional comment from Dan Kenigsberg on 2021-09-30 16:20:34 CST ---

@gouyang the fix seems simple enough. Can we request a backport to 4.8?

Comment 2 Ying Cui 2021-11-10 02:15:37 UTC
Could you have a look at this bug? from QE point of view, we would like to backport to 4.8.z as early as possible. Thanks.

Comment 3 Yaacov Zamir 2021-11-10 13:46:17 UTC
Aviv can you manually backport:
https://github.com/openshift/console/pull/9693

auto backport filed: https://github.com/openshift/console/pull/9693#issuecomment-965174630

Comment 5 Guohua Ouyang 2021-11-12 08:38:58 UTC
verifed on upstream release-4.8

Comment 8 errata-xmlrpc 2021-11-23 11:33:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.21 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4716


Note You need to log in before you can comment on or make changes to this bug.