Bug 200924 - futex + apic_timer BUG: spinlock lockup on CPU#0
futex + apic_timer BUG: spinlock lockup on CPU#0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_LOCKDEP
  Show dependency treegraph
 
Reported: 2006-08-01 12:43 EDT by John Reiser
Modified: 2015-01-04 17:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-12 02:22:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen photograph showing lockup traceback (90.13 KB, image/jpeg)
2006-08-01 12:43 EDT, John Reiser
no flags Details
serial console capture (27.49 KB, text/plain)
2006-08-02 10:06 EDT, John Reiser
no flags Details
captured serial console log (24.95 KB, text/plain)
2006-08-03 16:40 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2006-08-01 12:43:39 EDT
Description of problem: Machine freezes with BUG on VGA text console.


Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2431.fc6

How reproducible:
Once

Steps to Reproduce:
1. rpmbuild -ba --target i686 glibc-2.4.90-15.src.rpm
2.
3.
  
Actual results:
Lockup during running of tests as part of glibc build.

Expected results:
No lockup.

Additional info:
Comment 1 John Reiser 2006-08-01 12:43:39 EDT
Created attachment 133415 [details]
screen photograph showing lockup traceback
Comment 2 Dave Jones 2006-08-01 22:09:00 EDT
darn, I'd love to see the bit that had scrolled off the top of the screen.
Is this reproducable ? Any chance you could hook up a serial console ?
Comment 3 John Reiser 2006-08-02 10:06:29 EDT
Created attachment 133479 [details]
serial console capture

After trimming down the glibc tests to just the nptl subdirectory, it took
about 10 minutes to tickle the kernel BUG.  Here is the serial console, as
captured by minicom.
Comment 4 Dave Jones 2006-08-03 14:47:36 EDT
The PI Futex code did get some important fixes after 2431.  Can you repeat this
on the latest rawhide kernel?

(Btw, I also just sent a fix upstream for the incorrect tainting of your oopses.
That shouldn't happen).
Comment 5 John Reiser 2006-08-03 16:37:41 EDT
Booting kernel-2.6.17-1.2510.fc6 and running the glibc/nptl tests, I get no BUG.
 There was one "Maximum lock depth 1024 reached task: ld-linux.so.2 (4210)"
which happened the first time, but not in the next 4 passes, not even with a
reboot between pass 3 and pass 4.  So the probability seems less.  I will attach
the serial console log.

[Thank you for looking into the incorrect tainting, too.  I wondered what was
going on there; I use only modules from Fedora Core fc6t1 builds, and no others.]
Comment 6 John Reiser 2006-08-03 16:40:01 EDT
Created attachment 133584 [details]
captured serial console log

Note "Maximum lock depth 1024 reached ..." on line 260.
Comment 7 Dave Jones 2006-09-14 01:58:38 EDT
Is this still happening with the current builds ?
Comment 8 John Reiser 2006-09-15 09:47:46 EDT
I have not seen this problem since I last reported it on Aug.3.  "Yum update"
has been run approximately weekly.
Comment 9 Dave Jones 2006-10-12 02:22:08 EDT
ok, thanks.

Note You need to log in before you can comment on or make changes to this bug.