Bug 200926 - stateless vs lvm's .cache
stateless vs lvm's .cache
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-01 12:59 EDT by Jeff Law
Modified: 2014-03-16 23:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 13:04:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch file to update rwtab (361 bytes, patch)
2006-08-01 12:59 EDT, Jeff Law
no flags Details | Diff

  None (edit)
Description Jeff Law 2006-08-01 12:59:44 EDT
Description of problem:
We need to set up /etc/lvm/.cache as an empty bind mount so that pvcreate and
possibly other LVM related commands work.

Version-Release number of selected component (if applicable):


How reproducible:
Boot a box with nfsroot/stateless, then try:

vgcreate -v StatelessVG /dev/hda

It will fail, exiting with status 5 because vgcreate is unable to scribble
/etc/lvm/.cache.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeff Law 2006-08-01 12:59:46 EDT
Created attachment 133417 [details]
Patch file to update rwtab
Comment 2 Bill Nottingham 2006-08-01 13:04:14 EDT
Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.