Bug 2009391 (CVE-2021-39212) - CVE-2021-39212 ImageMagick: possible read or write in postscript files
Summary: CVE-2021-39212 ImageMagick: possible read or write in postscript files
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2021-39212
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2009392 2009393
Blocks: 2009395
TreeView+ depends on / blocked
 
Reported: 2021-09-30 14:22 UTC by Marian Rehak
Modified: 2021-11-02 16:07 UTC (History)
4 users (show)

Fixed In Version: ImageMagick 7.1.0-7, ImageMagick 6.9.12-22
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in ImageMagick in the Postscript File Handler component. An attacker could exploit this flaw which would, in some cases, lead to postscript files to be read and written to even when specifically excluded by a module policy in policy.xml.
Clone Of:
Environment:
Last Closed: 2021-10-20 14:08:32 UTC


Attachments (Terms of Use)

Description Marian Rehak 2021-09-30 14:22:53 UTC
Postscript files could be read and written when specifically excluded by a `module` policy in `policy.xml`.

Upstream Advisory:

https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-qvhr-jj4p-j2qr

Comment 1 Marian Rehak 2021-09-30 14:23:13 UTC
Created ImageMagick tracking bugs for this issue:

Affects: epel-8 [bug 2009393]
Affects: fedora-all [bug 2009392]

Comment 2 Product Security DevOps Team 2021-10-20 14:08:32 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-39212


Note You need to log in before you can comment on or make changes to this bug.