Bug 20094 - --buildarch no longer valid
Summary: --buildarch no longer valid
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-31 13:04 UTC by Bill Stephens
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-31 13:04:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Stephens 2000-10-31 13:04:06 UTC
The man page, and documentation show that rpm -ba --buildarch i686 should
work, however buildarch always comes back with --buildarch  Unknown
option.  After doing an RPM  --help, --buildarch is no longer listed. 
Which is wrong the man page or RPM?  I can't buid an i686 kernel to fix a
bug in the 2.2.16 kernel  without this option, unless there is some other
workaround.

Thanks,

Bill Stephens

Comment 1 Jeff Johnson 2000-11-02 14:43:46 UTC
The option --buildarch has been replaced. Use "--target=i686" instead (also
fixed in man page).

Comment 2 Aleksander Adamowski 2004-10-06 08:52:10 UTC
The book Max-RPM on http://www.rpm.org still lists the old --buildarch
option to rpmbuild.

Why not mark the old option deprecated in the documentation, but make
it still work in some verions of rpm through e.g. 3 years?

I've still hit this on RHEL 3, because all the Googlable documentation
on the web still lists the --buildarch option.


Note You need to log in before you can comment on or make changes to this bug.