Bug 200966 - frequent kernel crash
frequent kernel crash
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-01 16:49 EDT by Kai Engert (:kaie)
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 21:53:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel crash stack trace (3.14 KB, text/plain)
2006-08-01 16:49 EDT, Kai Engert (:kaie)
no flags Details
kernel crash stack trace #2 (3.12 KB, text/plain)
2006-08-01 17:56 EDT, Kai Engert (:kaie)
no flags Details

  None (edit)
Description Kai Engert (:kaie) 2006-08-01 16:49:17 EDT
Description of problem:
kernel frequently crashes

Version-Release number of selected component (if applicable):
2.6.17-1.2488.fc6

(I've been seeing this bug since many kernel revisions. I also crash frequently
on fc5 since about the same time as it started to appear on rawhide. might be
same bug on both systems? will try to produce an usb serial console dump on my
laptop - that does not have a real serial port...)

How reproducible:
just start the system and let it run, and cause some system activity, e.g. do a
"yum update -y". sooner or later it will crash.
Note my standard PC has a PCI wireless card as its only connection to the
internet, I'm using a recent madwifi snapshot that I compiled myself.

Steps to Reproduce:
1. boot computer
2. start some activity
3. wait
4. sooner or later kernel crashes
  
Actual results:
crash

Expected results:
no crash

Additional info:
I was able to use the serial console and get a stack trace.
Please see attached file.
I will check whether it is always the same stack.
Comment 1 Kai Engert (:kaie) 2006-08-01 16:49:20 EDT
Created attachment 133441 [details]
kernel crash stack trace
Comment 2 Kai Engert (:kaie) 2006-08-01 17:56:54 EDT
Created attachment 133450 [details]
kernel crash stack trace #2
Comment 3 Dave Jones 2006-08-01 21:53:32 EDT
can't do anything with tainted kernels.
Comment 4 Kai Engert (:kaie) 2006-08-02 09:15:28 EDT
Dave, if I understand your comment 3 correctly, you refuse to look into this,
because I compiled in the madwifi driver.

If this is a problem I can offer the following: I will uninstall the madwifi
kernel module. To solve my wireless only environment situation, I can connect an
external rj-45 to wireless gaming adapter, so that the kernel will use standard
cabled networking only.

I assume, if the kernel still crashes in that configuration, you are ok to look
into it. I will give that a try and reopen if it is indeed still crashing.
Comment 5 Kai Engert (:kaie) 2006-08-02 18:32:13 EDT
To my surprise, the system runs very stable when not using madwifi, but the
external ethernet-to-wireless bridge. Looks like the frequent crash was indeed
caused by that kernel module...

Note You need to log in before you can comment on or make changes to this bug.