Bug 200982 - patch causes diffstat to segfault when malloc perturb is used.
patch causes diffstat to segfault when malloc perturb is used.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: diffstat (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-08-01 19:02 EDT by Dave Jones
Modified: 2015-01-04 17:28 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.43-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-18 13:20:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch in question. (56.23 KB, text/plain)
2006-08-01 19:02 EDT, Dave Jones
no flags Details

  None (edit)
Description Dave Jones 2006-08-01 19:02:12 EDT
$ declare -x MALLOC_PERTURB_="106"
$ diffstat pm.diff 
Segmentation fault (core dumped)

gdb says...

Program terminated with signal 11, Segmentation fault.
#0  0x00002aaaaad3d9d2 in strcmp () from /lib64/libc.so.6
(gdb) bt
#0  0x00002aaaaad3d9d2 in strcmp () from /lib64/libc.so.6
#1  0x00002aaaaad93eee in tfind () from /lib64/libc.so.6
#2  0x00000000004017b2 in find_data (name=0x607260 "a/kernel/power/swap.c") at
diffstat.c:350
#3  0x0000000000402068 in do_file (fp=0x605010) at diffstat.c:930
#4  0x0000000000402df7 in main (argc=2, argv=0x7fffea0f6628) at diffstat.c:1487
#5  0x00002aaaaace6aa4 in __libc_start_main () from /lib64/libc.so.6
#6  0x0000000000400fd9 in _start ()
Comment 1 Dave Jones 2006-08-01 19:02:12 EDT
Created attachment 133452 [details]
the patch in question.
Comment 2 Tim Waugh 2007-01-15 07:35:38 EST
This seems to be fixed in 1.43.

Note You need to log in before you can comment on or make changes to this bug.