Bug 20099 - shell install scripts no longer work under RH7.0
Summary: shell install scripts no longer work under RH7.0
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-31 14:25 UTC by drector
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-02 20:14:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description drector 2000-10-31 14:25:06 UTC
I have several shell install scripts that used to work under 5.0, 5.2, 6.0
and 6.2, 
but cannot be interpreted under 7.0
For example, the WordPerfect 8.0 install cd-rom contains a 'install.wp'
script.
When I run it, I get several syntax errors, and the script doesn't run.
This script
worked fine under RedHat 6.2. Is there some new syntax for shell scripts?
Is there
a backwards compatibility switch?

Thanks for your help.

Dave Rector
drector@lanl.gov

Comment 1 Daniel Roesen 2000-10-31 14:34:51 UTC
The problem might be that RH7 uses bash2 as default instead of bash 1.x. Try 
running the install scripts with bash1 as interpreter (install bash1, change 
the first line of the script to point to bash1).

Comment 2 Jeff Johnson 2000-11-02 15:33:35 UTC
See also /usr/share/doc/bash-2.04/COMPAT for detailed list of changes between
bash1 and bash2.

Changing component to bash ...

Comment 3 drector 2000-11-02 16:11:37 UTC
Using bash1 did not work

bash2 gives the following message:
-------------------------------------------------------------
[root@brave cdrom]# ./install.wp 

  Please Wait ../install.wp: [: 16-22: integer expression expected
..
./install.wp: linux/ins/wpinstg: No such file or directory
--------------------------------------------------------------

bash1 (bash1-1.14.7-169 RPM for i386) gives a similar message:
-------------------------------------------------------------
[root@brave cdrom]# ./install.wp 

  Please Wait ../install.wp: [: integer expression expected before -lt
..
./install.wp: linux/ins/wpinstg: No such file or directory
-------------------------------------------------------------

Something else must be different, because this script gives no errors under
RedHat 6.2
There are many many errors after the first ones printed here. The script is very
long, and would perfer if I did not have to rewrite it.

Thanks for your help

Dave Rector
*:^)

Comment 4 drector 2000-11-02 20:14:48 UTC
OK, I have figured out my problem, there are two issues:

1) bash1 was required for script compatibility

2) libc5 was required to run the script.

The deletion of these two components from RH7.0 breaks many of my commercial
products as well as many things that I and others have developed.

Thanks for your help.
Dave Rector

Comment 5 Bernhard Rosenkraenzer 2000-11-03 09:40:54 UTC
It's not a bug then - we can't keep old compatibility cruft forever.

If you get any stuff that still requires libc 5.x, you should ask the vendor for an update. libc5 has been obsolete for a couple of years now.

The same goes for the change bash 1.x -> bash 2.x - bash 2.x is much more POSIX compliant, so it's the way to go. If something works in 1.x but not 2.x, it's a bug in the script.


Note You need to log in before you can comment on or make changes to this bug.