Bug 200990 - nesting symlinks fix for nfs
nesting symlinks fix for nfs
Status: CLOSED DUPLICATE of bug 196637
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Staubach
Brian Brock
:
Depends On:
Blocks: 196637
  Show dependency treegraph
 
Reported: 2006-08-01 20:55 EDT by Steve Dickson
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-10 14:24:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The upstream patch (1.94 KB, patch)
2006-08-01 20:55 EDT, Steve Dickson
no flags Details | Diff
Proposed patch (744 bytes, patch)
2006-09-22 14:03 EDT, Peter Staubach
no flags Details | Diff

  None (edit)
Description Steve Dickson 2006-08-01 20:55:31 EDT
Description of problem:
 When walking a path, the LOOKUP_CONTINUE flag is used by some filesystems
 (for instance NFS) in order to determine whether or not it is looking up
 the last component of the path. It this is the case, it may have to look
 at the intent information in order to perform various tasks such as atomic
 open.

 A problem currently occurs when link_path_walk() hits a symlink. In this
 case LOOKUP_CONTINUE may be cleared prematurely when we hit the end of the
 path passed by __vfs_follow_link() (i.e. the end of the symlink path)
 rather than when we hit the end of the path passed by the user.

 The solution is to have link_path_walk() clear LOOKUP_CONTINUE if and only
 if that flag was unset when we entered the function.

Additional info:
From: Peter Bojanic <pbojanic@clusterfs.com>
To: Kevin Anderson <kanderso@redhat.com>
Cc: Tom (Di) Wang <wangdi@clusterfs.com>, Andreas Dilger
<adilger@clusterfs.com>, Oleg Drokin <green@clusterfs.com>, Alex Tomas
<alex@clusterfs.com>
Subject: Fwd: patch-less lustre
Date: Thu, 16 Mar 2006 17:39:52 -0400

Kevin,

Sorry about the previous message. Try this one -- the patch should be  
attached properly this time.

Thanks,
Peter

Begin forwarded message:


>> From: Oleg Drokin <green@clusterfs.com>
>> Date: March 16, 2006 3:23:25 PM AST
>> To: Peter Bojanic <pbojanic@clusterfs.com>
>> Cc: wangdi <wangdi@clusterfs.com>, Andreas Dilger  
>> <adilger@clusterfs.com>
>> Subject: Re: patch-less lustre
>>
>> Hello!
>>
>> On Thu, Mar 16, 2006 at 11:45:41AM -0400, Peter Bojanic wrote:
>
>>>>>> - ACTION: CFS to send fixing nesting symlinks patch to Red Hat --
>>>>>> this appears to be the one we're stumbling on the most with RHEL4
>>
>>>> Can you help me out, by extracting this patch so I can forward it to
>>>> Red Hat?
>
>>
>> See attached. Not sure why RedHat is all that interested in it, the  
>> only other
>> user is probably NFS4.
>> We do not have the autorship of the patch. The patch is a complete  
>> email message
>> with all explanations from original author
>>
>> Bye,
>>     Oleg
Comment 1 Steve Dickson 2006-08-01 20:55:31 EDT
Created attachment 133453 [details]
The upstream patch
Comment 2 RHEL Product and Program Management 2006-09-07 15:04:35 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 RHEL Product and Program Management 2006-09-07 15:04:35 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 Peter Staubach 2006-11-10 14:24:48 EST

*** This bug has been marked as a duplicate of 196637 ***

Note You need to log in before you can comment on or make changes to this bug.