Bug 2010170 - chromium browser crashes upon launch
Summary: chromium browser crashes upon launch
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium
Version: 35
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-04 05:35 UTC by Vitor Hugo Nunes dos Santos
Modified: 2021-10-29 23:06 UTC (History)
7 users (show)

Fixed In Version: chromium-94.0.4606.81-1.fc34 chromium-94.0.4606.81-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-29 23:06:00 UTC
Type: Bug


Attachments (Terms of Use)
Reproduction of the bug (13.39 MB, video/webm)
2021-10-04 05:35 UTC, Vitor Hugo Nunes dos Santos
no flags Details

Description Vitor Hugo Nunes dos Santos 2021-10-04 05:35:44 UTC
Created attachment 1828812 [details]
Reproduction of the bug

Description of problem:

Upon launching chromium on a Fedora 35 Workstation install, it'll hang for a few seconds and crash.

If launched from the command line, you'll see that, although the window disappears, it keeps on running.

Version-Release number of selected component (if applicable):
94.0.4606.61

How reproducible:
10/10 times I tried, I ran into the error.

Steps to Reproduce:
1.Launch chromium
2.Wait for it to load
3.Try to open a page, any page, be it a webpage or the chrome://about page.
4.It crashes

Actual results:
The browser crashes.

Expected results:
I expected the browser to open and not crash.

Additional info:
Here's the command line output I got:
[vhns@fedora ~]$ chromium-browser 
[126144:126144:1004/021539.529283:ERROR:power_monitor_device_source_stub.cc(11)] Not implemented reached in virtual bool base::PowerMonitorDeviceSource::IsOnBatteryPower()
ATTENTION: default value of option allow_rgb10_configs overridden by environment.
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[126186:126186:1004/021539.829967:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
../../base/allocator/allocator_shim_default_dispatch_to_partition_alloc.cc(383) Check failed: address
../../base/allocator/allocator_shim_default_dispatch_to_partition_alloc.cc(383) Check failed: address
../../base/allocator/allocator_shim_default_dispatch_to_partition_alloc.cc(383) Check failed: address
Received signal 6
#0 0x55772d233b39 base::debug::CollectStackTrace()
#1 0x55772d138f26 Received signal 6
#0 0x55772d233b39 base::debug::StackTrace::StackTrace()
#2 0x55772d2330d4 base::debug::(anonymous namespace)::StackDumpSignalHandler()
#3 0x7fc9d47e6760 (/usr/lib64/libc.so.6+0x4275f)
#4 0x7fc9d483385c __pthread_kill_implementation
#5 0x7fc9d47e66b6 __GI_raise
#6 0x7fc9d47d07d3 __GI_abort
#7 0x55772d232bd5 base::debug::CollectStackTrace()
#1 0x55772d138f26 base::debug::BreakDebugger()
#8 0x55772d25f4c4 base::internal::PartitionGetSizeEstimate()
#9 0x7fc9c09e8568 <unknown>
#10 0x7fc9c09de827 <unknown>
#11 0x7fc9d489d7e2 gaih_inet.constprop.0
#12 0x7fc9d489e6c9 __GI_getaddrinfo
#13 0x5577274daa5b Received signal 6
#0 0x55772d233b39 net::AddressInfo::Get()
#14 0x55772752bc37 net::SystemHostResolverCall()
#15 0x55772751256a base::debug::CollectStackTrace()
#1 0x55772d138f26 net::HostResolverManager::ProcTask::DoLookup()
#16 0x55772750e59f base::internal::Invoker<>::RunOnce()
#17 0x55772d1d196e base::TaskAnnotator::RunTask()
#18 0x55772d31b616 base::debug::StackTrace::StackTrace()base::internal::TaskTracker::RunTask()
#19 0x55772d24fb43 
#2 0x55772d2330d4 base::debug::(anonymous namespace)::StackDumpSignalHandler()
#3 0x7fc9d47e6760 (/usr/lib64/libc.so.6+0x4275f)base::internal::TaskTrackerPosix::RunTask()
#20 0x55772d31aa45 base::debug::StackTrace::StackTrace()
#2 0x55772d2330d4 
#4 0x7fc9d483385c __pthread_kill_implementation
#5 0x7fc9d47e66b6 __GI_raise
#6 0x7fc9d47d07d3 __GI_abortbase::debug::(anonymous namespace)::StackDumpSignalHandler()
#3 0x7fc9d47e6760 (/usr/lib64/libc.so.6+0x4275f)
#4 0x7fc9d483385c __pthread_kill_implementation
#5 0x7fc9d47e66b6 __GI_raise
#6 0x7fc9d47d07d3 __GI_abort
#7 0x55772d232bd5 
#7 0x55772d232bd5 base::internal::TaskTracker::RunAndPopNextTask()
#21 0x55772d326772 base::debug::BreakDebugger()
#8 0x55772d25f4c4 base::internal::WorkerThread::RunWorker()
#22 0x55772d326e0d base::internal::PartitionGetSizeEstimate()
#9 0x7fc9c09e8568 <unknown>
#10 0x7fc9c09de827 <unknown>
#11 0x7fc9d489d7e2 gaih_inet.constprop.0
#12 0x7fc9d489e6c9 __GI_getaddrinfo
#13 0x5577274daa5b base::internal::WorkerThread::RunPooledWorker()
#23 0x55772d24feff base::(anonymous namespace)::ThreadFunc()
#24 0x7fc9d4831b17 start_thread
#25 0x7fc9d48b66a0 __clone3
  r8: 00007fc9c2a2b110  r9: 0000000000000000 r10: 0000000000000008 r11: 0000000000000246
 r12: 0000000000000006 r13: 00007fc9c2a2b3d0 r14: 0000119a00509710 r15: 00007fc9c2a2b2f0
  di: 000000000001eceb  si: 000000000001ecf7  bp: 000000000001ecf7  bx: 00007fc9c2a2d640
  dx: 0000000000000006  ax: 0000000000000000  cx: 00007fc9d483385c  sp: 00007fc9c2a2b040
  ip: 00007fc9d483385c efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 000000001e493a01 cr2: 0000000000000000
[end of stack trace]
[126144:126144:1004/021544.642350:ERROR:network_service_instance_impl.cc(333)] Network service crashed, restarting service.
../../base/allocator/allocator_shim_default_dispatch_to_partition_alloc.cc(383) Check failed: address
Received signal 6
#0 0x55f1e8d34b39 base::debug::CollectStackTrace()
#1 0x55f1e8c39f26 base::debug::StackTrace::StackTrace()
#2 0x55f1e8d340d4 base::debug::(anonymous namespace)::StackDumpSignalHandler()
#3 0x7f81b700e760 (/usr/lib64/libc.so.6+0x4275f)
#4 0x7f81b705b85c __pthread_kill_implementation
#5 0x7f81b700e6b6 __GI_raise
#6 0x7f81b6ff87d3 __GI_abort
#7 0x55f1e8d33bd5 base::debug::BreakDebugger()
#8 0x55f1e8d604c4 base::internal::PartitionGetSizeEstimate()
#9 0x7f81a3a11568 <unknown>
#10 0x7f81a3a07827 <unknown>
#11 0x7f81b70c57e2 gaih_inet.constprop.0
#12 0x7f81b70c66c9 __GI_getaddrinfo
#13 0x55f1e2fdba5b net::AddressInfo::Get()
#14 0x55f1e302cc37 net::SystemHostResolverCall()
#15 0x55f1e301356a net::HostResolverManager::ProcTask::DoLookup()
#16 0x55f1e300f59f base::internal::Invoker<>::RunOnce()
#17 0x55f1e8cd296e base::TaskAnnotator::RunTask()
#18 0x55f1e8e1c616 base::internal::TaskTracker::RunTask()
#19 0x55f1e8d50b43 base::internal::TaskTrackerPosix::RunTask()
#20 0x55f1e8e1ba45 base::internal::TaskTracker::RunAndPopNextTask()
#21 0x55f1e8e27772 base::internal::WorkerThread::RunWorker()
#22 0x55f1e8e27e0d base::internal::WorkerThread::RunPooledWorker()
#23 0x55f1e8d50eff base::(anonymous namespace)::ThreadFunc()
#24 0x7f81b7059b17 start_thread
#25 0x7f81b70de6a0 __clone3
  r8: 00007f81a4251110  r9: 0000000000000000 r10: 0000000000000008 r11: 0000000000000246
 r12: 0000000000000006 r13: 00007f81a42513d0 r14: 00000cca004b6f10 r15: 00007f81a42512f0
  di: 000000000001edc1  si: 000000000001edcc  bp: 000000000001edcc  bx: 00007f81a4253640
  dx: 0000000000000006  ax: 0000000000000000  cx: 00007f81b705b85c  sp: 00007f81a4251040
  ip: 00007f81b705b85c efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
 trp: 0000000000000000 msk: 000000001e493a01 cr2: 0000000000000000
[end of stack trace]
[126144:126144:1004/021548.592926:ERROR:network_service_instance_impl.cc(333)] Network service crashed, restarting service.
../../base/allocator/allocator_shim_default_dispatch_to_partition_alloc.cc(383) Check failed: address
../../base/allocator/allocator_shim_default_dispatch_to_partition_alloc.cc(383) Check failed: address
../../base/allocator/allocator_shim_default_dispatch_to_partition_alloc.cc(383) Check failed: address
[1004/021549.719647:ERROR:ptracer.cc(422)] ptrace: No such process (3)
[1004/021549.719731:ERROR:ptracer.cc(446)] Unexpected registers size 0 != 216
[1004/021549.719741:WARNING:process_reader_linux.cc(378)] Couldn't initialize main thread.
[1004/021553.963547:ERROR:scoped_ptrace_attach.cc(37)] process not stopped
[1004/021553.963599:ERROR:scoped_ptrace_attach.cc(27)] ptrace: No such process (3)
[1004/021553.964773:ERROR:scoped_ptrace_attach.cc(37)] process not stopped
[1004/021553.964805:ERROR:scoped_ptrace_attach.cc(27)] ptrace: No such process (3)
[1004/021553.964823:ERROR:scoped_ptrace_attach.cc(27)] ptrace: No such process (3)
[1004/021553.964837:ERROR:scoped_ptrace_attach.cc(27)] ptrace: No such process (3)
[1004/021553.964852:ERROR:scoped_ptrace_attach.cc(27)] ptrace: No such process (3)
[1004/021553.964864:ERROR:scoped_ptrace_attach.cc(27)] ptrace: No such process (3)
[1004/021553.965020:ERROR:file_io_posix.cc(144)] open /proc/126496/auxv: Permission denied (13)
[1004/021553.965046:ERROR:process_memory.cc(41)] short read
[1004/021553.965058:ERROR:process_snapshot_linux.cc(75)] Couldn't read exception info
[1004/021553.965287:ERROR:scoped_ptrace_attach.cc(45)] ptrace: No such process (3)
[1004/021553.965517:ERROR:scoped_ptrace_attach.cc(27)] ptrace: Operation not permitted (1)
Killed
[vhns@fedora ~]$


Attached is a video of me reproducing the bug to the best of my abilities.
Please do ask for more info if necessary.

Comment 1 Justin Zobel 2021-10-04 22:39:42 UTC
I can also confirm this behaviour on two devices.

Comment 2 Justin Zobel 2021-10-05 00:16:47 UTC
I grabbed https://download-chromium.appspot.com/ in the interim to keep working until the issue is resolved. I backed up my Chromium config and cache and it seems to be working OK with them.

Comment 3 Tom "spot" Callaway 2021-10-05 20:35:18 UTC
It looks like this bug: 
https://bugs.chromium.org/p/chromium/issues/detail?id=1221442

But the fix for that is in 94.0.4606.61. Can you please confirm you're running 94.0.4606.61 and see this issue? Simplest way to be sure is to reboot, then rpm -q chromium, then run chromium-browser from the command line.

Comment 4 Tom "spot" Callaway 2021-10-05 21:13:33 UTC
Nevermind, I can reproduce in a VM. Very weird though. Disabling systemd-resolve (and rebooting) does make the crash go away, as it did for the previous bug.

Comment 5 Rick Huijzer 2021-10-06 08:26:33 UTC
I can confirm this behaviour on multiple devices. Downgrading chromium-94.0.4606.61-1.fc34.x86_64 to chromium-89.0.4389.90-3.fc34.x86_64 works fine.

Comment 6 Tom "spot" Callaway 2021-10-06 19:52:46 UTC
I've got a fix for this coming. Should have it out in the next day or two.

Comment 7 Vitor Hugo Nunes dos Santos 2021-10-06 23:15:49 UTC
>But the fix for that is in 94.0.4606.61. Can you please confirm you're running 94.0.4606.61 and see this issue? Simplest way to be sure is to reboot, then rpm -q chromium, then run chromium-browser from the command line.

Yup, even after this procedure it's broken.

Comment 8 Fedora Update System 2021-10-14 14:40:22 UTC
FEDORA-2021-5ffabdc080 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-5ffabdc080

Comment 9 Fedora Update System 2021-10-14 14:40:23 UTC
FEDORA-2021-116eff380f has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-116eff380f

Comment 10 Fedora Update System 2021-10-14 15:58:01 UTC
FEDORA-2021-116eff380f has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-116eff380f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-116eff380f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2021-10-14 18:55:15 UTC
FEDORA-2021-5ffabdc080 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-5ffabdc080`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-5ffabdc080

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Justin Zobel 2021-10-15 00:53:11 UTC
I just tried the F35 command and got no upgrade:
sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-5ffabdc080
[sudo] password for justin: 
Fedora 35 - x86_64 - Test Updates                                                                                                                                                                            22 kB/s |  33 kB     00:01    
Fedora 35 - x86_64 - Test Updates                                                                                                                                                                           1.1 MB/s | 1.8 MB     00:01    
Last metadata expiration check: 0:00:03 ago on Fri 15 Oct 2021 11:20:35.
No security updates needed, but 34 updates available
Dependencies resolved.
Nothing to do.
Complete!

I got no Chromium download and even sudo dnf upgrade showed only flatpak and mesa updates.

Comment 13 Fedora Update System 2021-10-15 19:22:19 UTC
FEDORA-2021-116eff380f has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Vitor Hugo Nunes dos Santos 2021-10-16 18:22:23 UTC
Yup, the update fixes it.

Comment 15 Adam Jędrzejowski 2021-10-20 16:06:15 UTC
Is there any chance for Fedora 33 to get this udpate?

Comment 16 Adam Jędrzejowski 2021-10-26 13:50:56 UTC
I have been using RPM's from https://koji.fedoraproject.org/koji/buildinfo?buildID=1844858 for 3 days, and I they seems good

Comment 17 Fedora Update System 2021-10-29 23:06:00 UTC
FEDORA-2021-5ffabdc080 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.