Bug 201030 - Epoch 1 required for nfs-utils to keep FC5 -> FC6 upgrade path
Epoch 1 required for nfs-utils to keep FC5 -> FC6 upgrade path
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
: EasyFix
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-08-02 07:57 EDT by Matthias Saou
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 09:36:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2006-08-02 07:57:01 EDT
Since the latest nfs-utils package in FC5 updates got an epoch of 1 set because
of the release field problems, the current package in FC development (to become
FC6) also needs its epoch to be set to 1 in order to preserve the upgrade path
from FC5 to FC6.
Comment 1 Steve Dickson 2006-08-02 08:11:19 EDT
Why, since the nfs-utils in FC6 will be version 1.0.9?
Comment 2 Matthias Saou 2006-08-02 08:18:51 EDT
Because a higher epoch always wins : 1:1.0.8 > 0:1.0.9
Comment 3 Matthias Saou 2006-08-03 09:36:54 EDT
Looks like Warren fixed this today. See the comment in bug #196359.

Don't forget to learn how rpm's E-V-R (epoch, version, release) comparison
works, as being careful could have avoided this problem entirely.

Note You need to log in before you can comment on or make changes to this bug.