Bug 201054 - weak-updates requires /usr/lib/rpm/redhat/rpmsort but doesn't prereq redhat-rpm-config
weak-updates requires /usr/lib/rpm/redhat/rpmsort but doesn't prereq redhat-r...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Masters
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-08-02 11:36 EDT by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-03 03:49:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-08-02 11:36:10 EDT
This then leads to scriptlet spew during install.

But rather than adding another requires and possibly making things more insane,
it's probably better to have weak-updates just fail gracefully if rpmsort isn't
present
Comment 1 Jon Masters 2006-08-03 03:49:07 EDT
I rewrote the relevent part of that script as a funky bit of shell so rpmsort is
not required and we can skip out on the extra dep. Hopefully, this concludes the
fun and games with that script.

Note You need to log in before you can comment on or make changes to this bug.