Bug 201066 - yum info does not report installed-from repo
yum info does not report installed-from repo
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-02 12:19 EDT by Don Russell
Modified: 2014-01-21 17:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 14:10:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Russell 2006-08-02 12:19:51 EDT
Description of problem:
When a packageis installed, "yum info <package name>" reports the repo as
"installed"


Version-Release number of selected component (if applicable)
2.6.1-0.fc5


How reproducible:
always - this is an enhancement request

Steps to Reproduce:
1. choose a package that is already installed, or install a new package
2. yum info <package name>
3. check the "repo:" line
  
Actual results:
installed

Expected results:
installed from extras
or
installed from core
or
installed from *unknown*
etc. Some indication of where the package likely came from.


Additional info:
The resaon I want this information is for when reporting bugs, I know if it's a
"core" issue or an "extras" issue. Case in point, I opened a bug against ncftp
using Core... later found out it s/b extras....

Here is the display from yum info ncftp.

$ yum info ncftp
Loading "installonlyn" plugin
Setting up repositories
core                                                                 [1/3]
updates                                                              [2/3]
extras                                                               [3/3]
Reading repository metadata in from local files
Installed Packages
Name   : ncftp
Arch   : i386
Epoch  : 2
Version: 3.1.9
Release: 4.fc5
Size   : 1.1 M
Repo   : installed
Summary: Improved console FTP client

Description:
 Ncftp is an improved FTP client. Ncftp's improvements include support
for command line editing, command histories, recursive gets, automatic
anonymous logins, and more.
Comment 1 Seth Vidal 2006-08-02 12:22:55 EDT
There's no way to definitely know where the package came from once it is
installed. It would be a guess based on what is currently in repos but it
wouldn't be definitive. I don't like giving out best-guess information that way.
Comment 2 Don Russell 2006-08-02 12:54:05 EDT
I agree.... how about something a little more "vague", but valuable?

On the "Repo:" line, list the repos yum fins the package in:

i.e.
Repo: Instaled, Core
or
Repo: Installed, Extras

It doesn't mean it was necessarily installed FROM those repos, but it means
those packages were found in those repos...

The reason I want that info is to help with bug reporting. Even if I instal a
package from Core, then later it is moved to Extras, the "yum info" will
correctly report it as "Installed, Exatras"... aiding in where to get more info,
or where to report bugs etc.

Of course, I am only mentioning "Core" and "Extras" here, but it should include
any repos yum is configured for...

What do you think? :-)

Comment 3 Jeroen van Meeuwen 2006-08-11 08:00:58 EDT
One can find the repository the package *currently* is in, with a command like:

; See if 'package' is from repo 'extras'
# yum --disablerepo=* --enablerepo=extras list | grep -v "installed" | grep package

You (optionally) need to grep -v installed to prevent the reporting of the
installed package as well. yum does report the installed packages regardless of
the repository the installed package came from (and whether the repository the
package came from is enabled or disabled). Appearantly, yum doesn't know, and
doesn't care either.
Comment 4 Don Russell 2006-08-11 10:08:24 EDT
I saw a message earlier this week (7 Aug 2006 on the fedora-announce-list)that
discussed something called "Fedora Usability" and how it's goal is to make
things more intuitive.

What is more intuitive than "yum info <package name>"? What do I expect to learn
from this command? Perhaps size of the package, perhaps whether it is installed
or not, which repo it could be found in, a description of the package and so on.

In your example, I don't want to guess "is it in extras"? Is it in core? "yum
info..." already looks based on the yum config files... I just want yum to tell
me what it knows...

yum --disablerepo=* enablerepo=extras list..... is WAY too complicated to learn
the answer to a very simple question? Which (yum configured) repos contain a
specific package. yum already determines the answer but doesn't report it. I'm
asking that it does report it, even when the package is already installed.

repo: installed, extras
repo: installed
repo: core
repo: extras
etc



Comment 5 Seth Vidal 2006-08-11 10:19:30 EDT
look at:
showdupesfromrepos

in the yum man page.

See if that helps you.
Comment 6 Jeroen van Meeuwen 2006-08-11 11:12:58 EDT
The man page of yum-2.6.1-0.fc5 does not have such information.
Comment 7 Seth Vidal 2006-08-11 11:16:26 EDT
sorry, yum.conf man page.
Comment 8 Don Russell 2006-08-11 12:20:01 EDT
I tried setting the showdupesfromrepos=1 option in the yum.conf file but it did
not have the desired effect.

Prior to the change "yum info mrtg" (installed on my system) showed me 
   Repo: installed
After the change it now shows
   Repo: core

In both cases, "yum info ethereal" (not installed on my system) shows me
   Repo: updates

When I run "yum info <package>", I get the following messages:
Setting up repositories:
core
updates
extras

It appears a special case "installed" repo is implied because "yum info mrtg"
shows "repo: installed" on my system.

I gather yum is actually going to look for the specified package in each of
those repositories, and tell me which *one* the package was found in.
I would like (as a yum RFE) for it to tell me *all* the repos it found the
package in.

So, in my example of mrtg, yum info would show me
   Repo: installed, core
or Repo: installed, core, updates


Note You need to log in before you can comment on or make changes to this bug.