Bug 2010683 - sound card disappears after relogin
Summary: sound card disappears after relogin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wireplumber
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact:
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F35FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2021-10-05 10:52 UTC by Kamil Páral
Modified: 2021-10-11 13:12 UTC (History)
7 users (show)

Fixed In Version: wireplumber-0.4.3-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-08 18:27:44 UTC
Type: Bug


Attachments (Terms of Use)
missing audio devices due to this bug (55.89 KB, image/png)
2021-10-05 10:53 UTC, Kamil Páral
no flags Details
rpm-qa.txt (58.73 KB, text/plain)
2021-10-05 10:53 UTC, Kamil Páral
no flags Details
system journal after triggering the bug (426.13 KB, text/plain)
2021-10-05 10:53 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2021-10-05 10:52:32 UTC
Description of problem:
If you log out and log back in to your GNOME session, suddenly no sound card is available. That has unpleasant consequences. Not only you can't play any sound, but also apps trying to play a sound either wait/hang indefinitely (e.g. a youtube video in firefox spins forever, can't play just the video without audio) or crash (virt-manager did that, IIRC).

In order to trigger this, just log out and log back in without any wait time. You'll see no audio icon in the top right corner, and no audio devices present in gnome-control-center -> Sound. See the screenshot.

If I replace wireplumber with pipewire-media-session, the problem is gone.

Version-Release number of selected component (if applicable):
wireplumber-0.4.2-1.fc35.x86_64 (broken)
pipewire-media-session-0.3.38-1.fc35.x86_64 (works)
gnome-shell-41.0-1.fc35.x86_64

How reproducible:
always

Steps to Reproduce:
1. install clean F35 Workstation, set up a user
2. log in, see the audio icon in top right
3. log out
4. log in again
5. see no audio icon in top right, see no audio devices in gnome-control-center->Sound, see app issues when trying to play a sound or touch the audio device in general
6. sudo dnf swap wireplumber pipewire-media-session
7. reboot
8. repeat the steps, see no issues this time

Additional info:
Waiting for 30+ seconds in gdm before another login avoids this bug, it seems.
Also, this bug doesn't seem to be triggered when you change users, instead of relogging as the same user.

Comment 1 Kamil Páral 2021-10-05 10:53:00 UTC
Created attachment 1829353 [details]
missing audio devices due to this bug

Comment 2 Kamil Páral 2021-10-05 10:53:19 UTC
Created attachment 1829354 [details]
rpm-qa.txt

Comment 3 Kamil Páral 2021-10-05 10:53:36 UTC
Created attachment 1829355 [details]
system journal after triggering the bug

Comment 4 Kamil Páral 2021-10-05 10:58:05 UTC
Proposing as a Final blocker:
"The installed system must be able to play back sound with gstreamer-based applications. "
https://fedoraproject.org/wiki/Fedora_35_Beta_Release_Criteria#Working_sound
"Shutting down, rebooting, logging in and logging out must work using standard console commands and the mechanisms offered (if any) by all release-blocking desktops. "
"Logging in must transfer the user from the login screen/prompt to their working environment, and logging out must return the user to the environment from which they logged in, working as expected. "
https://fedoraproject.org/wiki/Fedora_35_Beta_Release_Criteria#Shutdown.2C_reboot.2C_login.2C_logout

This doesn't work as expected (as the criterion says). Relogging without a delay is also quite a common scenario, I think (that's how I found this). Quirks in gnome-shell sometimes make you to relog. Gnome-shell extensions updates ask you to relog. Changing your user groups needs you to relog. And switching between a Wayland and X11 session also requires you to relog (that was my case to spot this).

Comment 5 Adam Williamson 2021-10-05 16:24:08 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/499 , marking accepted.

Comment 6 Fedora Update System 2021-10-08 11:43:22 UTC
FEDORA-2021-b70755fdc3 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b70755fdc3

Comment 7 Lukas Ruzicka 2021-10-08 12:26:09 UTC
I can confirm that the latest update (comment #6) fixes the issue. The sound works after multiple log outs and log ins.

Comment 8 Fedora Update System 2021-10-08 18:27:44 UTC
FEDORA-2021-b70755fdc3 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Kamil Páral 2021-10-11 08:20:18 UTC
I can also confirm this is fixed.

Comment 10 Andrew 2021-10-11 13:12:16 UTC
Might be related and still exists: bug #2012848


Note You need to log in before you can comment on or make changes to this bug.