Bug 2011274 - flathub filtered repo seems missing from F36 install
Summary: flathub filtered repo seems missing from F36 install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://ask.fedoraproject.org/t/commo...
Depends On:
Blocks: F36FinalFreezeException 1982741
TreeView+ depends on / blocked
 
Reported: 2021-10-06 10:23 UTC by Kamil Páral
Modified: 2022-09-21 10:21 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-20 23:29:29 UTC
Type: Bug
bcotton: fedora_prioritized_bug-


Attachments (Terms of Use)
GNOME Software verbose log (87.20 KB, text/plain)
2022-04-05 19:00 UTC, Daniel Rusek
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-software issues 1710 0 None None None 2022-04-04 15:39:11 UTC

Description Kamil Páral 2021-10-06 10:23:26 UTC
Description of problem:
I did a clean F35 Workstation install from Fedora-Workstation-Live-x86_64-35-20211005.n.0.iso. Regardless of whether I enable or not enable third party repos in the initial setup, I don't see flathub filtered repo [1] anywhere. 

$ flatpak remotes
Name   Options
fedora system,oci

In gnome-software, there are 4 repositories listed under "Fedora Third Party Repositories", but flathub filtered repo is not one of them. Under "Applications (Flatpak)" section it is not listed either.

So overall it seems disabled by default (even if I enable third party repos in initial setup/gnome-software) and I can't even find a place to enable it.

Note: I know that bug 1982741 comment 3 speaks about:
$ sudo fedora-third-party enable
but I don't think all users are expected to find out about it and run it manually.

Has the Change [1] failed to deliver this in F35? It doesn't state any status.

[1] https://fedoraproject.org/wiki/Changes/Filtered_Flathub_Applications

Version-Release number of selected component (if applicable):
fedora-flathub-remote-1-1.fc35.noarch
fedora-third-party-0.6-1.fc35.noarch
fedora-workstation-repositories-35-1.fc35.noarch
gnome-initial-setup-41.0-1.fc35.x86_64
gnome-software-41.0-1.fc35.x86_64

How reproducible:
always

Steps to Reproduce:
1. install clean F35 and try to find the flathub filtered repo anywhere

Comment 1 Owen Taylor 2021-10-06 14:03:25 UTC
OK, there are two separate things going on here:

 A) With the selinux problems in bug 2001837, opting-in through gnome-initial-setup leaves things in an inconsistent state - fedora-third-party thinks that the user has opted in, but the repositories are not actually enabled. Since fedora-third-party thinks that a user has made a selection, no info-bar is shown when gnome-software runs, and there is no option to opt-in again.

 B) There is problem with the GNOME Software repositories dialog design. The way we decided to do it is that the switch for third-party repositories only affects *future* third-party repositories that have not yet been added to the system - and is labelled that way. With the idea that the user who wants to opt-in later can toggle the switch then turn on the individual repositories. But we only create third-party Flatpak repositories when the user opts-in, so if the user has opted out intiially (or hit the bug in A), they don't see the Flathub repository *at all*, and have no way to create it.

Fixing B) is probably going to require switching Flatpak repositories to the enable/disable model, which is not a F35 change at this point - the most obvious fix would be require a Flatpak change to allow files in /etc/flatpaks/remotes.d to create *disabled* repositories.

So, given fix for problem A, here's a stab at some text for CommonBugs:

 When you install Fedora 35 or update to Fedora 35, if you don't opt-in to Fedora Third-party repositories initially, you are supposed to be able to opt-in through the GNOME Software repositories dialog later. However, the "Fedora Flathub Selection" third-party repository will not be visible there, so cannot be enabled. As a workaround, from the command line, run:

  sudo fedora-third-party disable
  sudo fedora-third-party enable

This will result in *all* third-party repositories being created and enabled. You can disable any repositories you don't want through the GNOME Software repositories dialog.

Comment 2 Milan Crha 2021-10-06 14:58:17 UTC
(In reply to Owen Taylor from comment #1)
>  B) There is problem with the GNOME Software repositories dialog design. The
> way we decided to do it is that the switch for third-party repositories only
> affects *future* third-party repositories that have not yet been added to
> the system - and is labelled that way.

I think it can be handled by the upstream, though it needs a design input.

Allan, could you make it upstream, please?

What I'd think of is to hide respective third party repositories in the dialog when the fedora-third-party reports "disabled" state. There would need to be a new switch for it, probably replacing the current one (that you described, for the future repos). The `--config-only` makes it even more complicated.

Comment 3 Kamil Páral 2021-10-06 14:59:39 UTC
Thanks for the CommonBugs draft, Owen. Adding a tag.

Comment 4 Kamil Páral 2022-03-15 12:45:07 UTC
(In reply to Owen Taylor from comment #1)
>  When you install Fedora 35 or update to Fedora 35, if you don't opt-in to
> Fedora Third-party repositories initially, you are supposed to be able to
> opt-in through the GNOME Software repositories dialog later. However, the
> "Fedora Flathub Selection" third-party repository will not be visible there,
> so cannot be enabled.

This is still broken on Fedora-Workstation-Live-x86_64-36_Beta-1.1.iso

Comment 5 Kamil Páral 2022-03-25 07:53:08 UTC
Proposing as a prioritized bug. This is preventing many of our users from using the flathub filtered repo. A quick summary is here:
https://ask.fedoraproject.org/t/common-issues/18958

Comment 6 Milan Crha 2022-04-04 07:33:41 UTC
gnome-software bug report from Fedora 36:
https://gitlab.gnome.org/GNOME/gnome-software/-/issues/1710

Owen, where should the fix go, please? I'm not sure from the above. As the workaround is to use the fedora-third-party and as gnome-software calls it under the hood, then one might be able to do the same from the gnome-software, no? Even, the Repositories dialog adds "--config-only" to the command, while the banner in the Explore page calls the fedora-third-party without the "--config-only" argument, when the user clicks the "Enable" button.

Comment 7 Daniel Rusek 2022-04-04 21:36:30 UTC
Switching the Fedora version to 36 since the original issue still seems to happen there (and most likely also on Rawhide).

Comment 8 Owen Taylor 2022-04-05 14:30:23 UTC
Sorry for not updating here. This is largely fixed by:

 https://bodhi.fedoraproject.org/updates/FEDORA-2022-f2efc42252

for new installs of F36 and later, the "Fedora Flathub Selection" will appear under Third Party Repositories whether you opt in or opt out. (Post-Beta fix)

Unfortunately, it's not fixed for people that installed or upgraded to Fedora 35 -if someone installed or upgraded to Fedora 35 and opt-out from third-party software, they'll need to run:

 $ sudo fedora-third-party enable

from a terminal to get this repository. (They can then disable things again if they want and it wont' go away.)


It wouldn't be impossible to have a special-case to to improve things for people who installed F35 or F36-beta and opted out from Third-party Repositories by adding a disabled "Fedora Flathub Selection" remote if it's missing, but I'm reluctant to add that complexity. I think most people who installed F35 and want applications from Flathub have already figured out something by now.

Comment 9 Milan Crha 2022-04-05 15:25:55 UTC
Following the downstream bug I'm closing this, also due to the changes been done on the fedora-third-party side, nothing to be done on the gnome-software side.

Comment 10 Kamil Páral 2022-04-05 15:30:33 UTC
Owen, thanks for the update. This is great. I tested Fedora-Workstation-Live-x86_64-36-20220405.n.0.iso and it behaves as you describe - I can enable the flathub filtered repo in gnome-software.

However, when I upgrade from F35 (which had no third party repos enabled) to F36, I still *don't* see the flathub filtered repo in gnome-software. I have 
fedora-third-party-0.9.1-1.fc36. Is that intentional? I would hope that by upgrading to F36, this problem would be solved for everyone.

Comment 11 Owen Taylor 2022-04-05 15:36:10 UTC
kparal: I describe the situation when upgrading from F35 in comment 8.

I do need to do a new fedora-third-party release for 2071250, so I'll think a bit more about whether there's anything we can do.

Comment 12 Daniel Rusek 2022-04-05 18:58:27 UTC
Fedora 36 Beta (clean installation, installed from the official beta iso, then fully updated) with fedora-third-party-0.9.1-1.fc36.noarch and gnome-software-42.0-1.fc36.x86_64. Clicking the "Enable New Repositories" in Software Repositories window still does not enable Flathub (the issue described in https://gitlab.gnome.org/GNOME/gnome-software/-/issues/1710 still seems to be the same):

$ flatpak remotes --show-disabled
Name           Options
fedora         system,oci
fedora-testing system,disabled,oci

I have tried it multiple times and have also tried rebooting the system multiple times, but no luck.

I am attaching a verbose GNOME Software log from when I clicked the button.

Comment 13 Daniel Rusek 2022-04-05 19:00:19 UTC
Created attachment 1870934 [details]
GNOME Software verbose log

GNOME Software log from when clicking the "Enable New Repositories" button.

Comment 14 Kamil Páral 2022-04-06 09:12:41 UTC
(In reply to Owen Taylor from comment #11)
> kparal: I describe the situation when upgrading from F35 in comment 8.

Not sure whether that was a typo, but that only speaks about upgrading *to* F35, not to F36. So I thought upgrading to the latest F36 would solve this for all. So if I understand you correctly, that's not the case, only fresh installs of F36 post-Beta composes will have the filtered flathub option shown in gnome-software.

> I do need to do a new fedora-third-party release for 2071250, so I'll think
> a bit more about whether there's anything we can do.

It would be great if you could fix this at least for upgrades to F36. I agree that existing F35 users either already figured out what to do or don't need it. But if not even the upgrade to F36 fixes this, we will basically perpetually need to deal with users who'll complain that their gnome-software is missing the filtered flathub option, while their friends have it. The Common Issue [1] can't be marked as solved, because it will still apply to everyone affected who upgraded (=still affected).

[1] https://ask.fedoraproject.org/t/common-issues/18958

(In reply to Daniel Rusek from comment #12)
> Fedora 36 Beta (clean installation, installed from the official beta iso,
> then fully updated) with fedora-third-party-0.9.1-1.fc36.noarch and
> gnome-software-42.0-1.fc36.x86_64. Clicking the "Enable New Repositories" in

Yes, F36 Beta installations are affected in the same way as F35. "Enable New Repositories" is not the right button. You should see "Fedora Flathub Selection" repo in the Third Party Repositories list. As explain above, that's not the case unless you do a fresh install with a very recent F36 compose. However, you can work around it by following instructions in the linked Common Issue [1].

Comment 15 Daniel Rusek 2022-04-06 12:36:10 UTC
Thanks, I can confirm that when using the latest F36 compose (Fedora-Workstation-Live-x86_64-36-20220405.n.0.iso), the "Fedora Flathub Selection" is now displayed and can be enabled without issue. The only problem that I noted is that I had to reboot the computer before the Flathub entries (Minecraft, for example) actually appeared in GNOME Software (even checking for updates manually on the Updates tab did not help). But that is probably an unrelated issue...

Comment 16 Daniel Rusek 2022-04-06 13:20:20 UTC
I have reported the unrelated issue mentioned in my previous comment here: https://gitlab.gnome.org/GNOME/gnome-software/-/issues/1712

Comment 17 Luna Jernberg 2022-04-06 14:20:59 UTC
Was discussed in todays Prio Bugs meeting

<mattdm, bcotton_> #agreed BZ 2011274 is softly rejected as a Prioritized Bug. We would like to see this fixed in short order, but don't want to mandate it

Comment 18 Fedora Update System 2022-04-07 04:32:19 UTC
FEDORA-2022-1ed936a3ac has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-1ed936a3ac

Comment 19 Kamil Páral 2022-04-07 16:48:24 UTC
(In reply to Fedora Update System from comment #18)
> FEDORA-2022-1ed936a3ac has been submitted as an update to Fedora 36.
> https://bodhi.fedoraproject.org/updates/FEDORA-2022-1ed936a3ac

I tested upgrading from F36 Beta and from F35. In both cases, just installing fedora-third-party-0.10-1.fc36 created the "Fedora Flathub Selection" option in gnome-software. It was not needed to run "dnf reinstall fedora-flathub-remote" as the update description claims.

So unless I overlooked something, this looks like a complete solution for everyone who upgrades to F36. Great work, Owen.

Comment 20 Fedora Update System 2022-04-07 18:01:18 UTC
FEDORA-2022-1ed936a3ac has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-1ed936a3ac`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-1ed936a3ac

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Kamil Páral 2022-04-20 13:21:53 UTC
Ooops, I completely forgot about the Final freeze and didn't ask for a freeze exception. Doing that now. This is quite important to be pushed before Final.

Comment 22 Adam Williamson 2022-04-20 21:44:51 UTC
+5 in https://pagure.io/fedora-qa/blocker-review/issue/767 , marking accepted.

Comment 23 Fedora Update System 2022-04-20 23:29:29 UTC
FEDORA-2022-1ed936a3ac has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.