Bug 2011359 - Change telemeter to report the Application Services product usage metrics
Summary: Change telemeter to report the Application Services product usage metrics
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.9
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.9.z
Assignee: Simon Pasquier
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 2005971
Blocks: 2011339
TreeView+ depends on / blocked
 
Reported: 2021-10-06 13:31 UTC by Ken Finnigan
Modified: 2021-10-26 17:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 2005971
Environment:
Last Closed: 2021-10-26 17:22:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 1420 0 None open Bug 2011359: Backport Application Services metric to 4.9 release 2021-10-15 19:13:03 UTC
Red Hat Product Errata RHBA-2021:3935 0 None None None 2021-10-26 17:23:04 UTC

Description Ken Finnigan 2021-10-06 13:31:50 UTC
+++ This bug was initially created as a clone of Bug #2005971 +++

Description of problem:
Application Services products need the ability to capture core usage for billing customers on a usage basis.

An operator has been developed to capture the usage and product a metric, but we need the data captured to be sent to Telemeter to feed into systems such as Subscription Watch.

Version-Release number of selected component (if applicable): 4.9


How reproducible:
N/A

Steps to Reproduce:
N/A

Actual results:
N/A

Expected results:
N/A

Additional info:
N/A

--- Additional comment from OpenShift Automated Release Tooling on 2021-10-06 03:54:07 UTC ---

Elliott changed bug status from MODIFIED to ON_QA.
This bug is expected to ship in the next 4.10 release created.

Comment 3 Junqi Zhao 2021-10-18 06:45:57 UTC
tested with PR, "appsvcs:cores_by_product:sum" is in telemeter client/server configuration
client: 
# oc -n openshift-monitoring get cm telemetry-config -o jsonpath="{.data.metrics\.yaml}" | grep "appsvcs:cores_by_product:sum" -C4
#
# owners: (https://github.com/redhat-developer/application-services-metering-operator)
#
# The current amount of CPU used by Application Services products, aggregated by product name.
- '{__name__="appsvcs:cores_by_product:sum"}'

server: https://github.com/rhobs/configuration/blob/main/configuration/telemeter/metrics.json
note: need to roll out the new configuration to production, then we can see the metrics in telemeter server

Comment 6 Junqi Zhao 2021-10-21 09:38:28 UTC
the fix is in 4.9.0-0.nightly-2021-10-18-130840 and later builds, based on Comment 3, set to VERIFIED

Comment 9 errata-xmlrpc 2021-10-26 17:22:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.4 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3935


Note You need to log in before you can comment on or make changes to this bug.