Bug 2011460 - ImageStream with RHCOS version tag needed for RHODS GPU support
Summary: ImageStream with RHCOS version tag needed for RHODS GPU support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Driver Toolkit
Version: 4.8
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.8.z
Assignee: dagray
QA Contact: Walid A.
URL:
Whiteboard:
: 2011024 (view as bug list)
Depends On: 2008619
Blocks: 2011024
TreeView+ depends on / blocked
 
Reported: 2021-10-06 16:04 UTC by OpenShift BugZilla Robot
Modified: 2021-10-29 20:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-27 08:15:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift driver-toolkit pull 65 0 None open [release-4.8] [release-4.9] Bug 2011460: Add imagestream for driver-toolkit 2021-10-14 18:47:40 UTC
Github openshift kubernetes pull 1005 0 None open Bug 2011460: UPSTREAM: <carry>: openshift-hack/images/os/Dockerfile: Add io.openshift.build.versions, etc. 2021-10-08 07:16:32 UTC
Red Hat Product Errata RHBA-2021:3927 0 None None None 2021-10-27 08:15:49 UTC

Comment 4 Walid A. 2021-10-19 16:38:12 UTC
Verfied on OCP 4.8.0-0.nightly-2021-10-18-115810:

# oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.8.0-0.nightly-2021-10-18-115810   True        False         126m    Cluster version is 4.8.0-0.nightly-2021-10-18-115810

# oc get imagestreams -n openshift | grep driver
driver-toolkit                                        image-registry.openshift-image-registry.svc:5000/openshift/driver-toolkit                                        48.84.202110152059-0,latest                              2 hours ago
jboss-datavirt64-driver-openshift                     image-registry.openshift-image-registry.svc:5000/openshift/jboss-datavirt64-driver-openshift                     1.0,1.1,1.2,1.3,1.4,1.5,1.6,1.7                          2 hours ago

# oc describe is -n openshift driver-toolkit
Name:			driver-toolkit
Namespace:		openshift
Created:		2 hours ago
Labels:			<none>
Annotations:		include.release.openshift.io/ibm-cloud-managed=true
			include.release.openshift.io/self-managed-high-availability=true
			include.release.openshift.io/single-node-developer=true
			openshift.io/image.dockerRepositoryCheck=2021-10-19T14:16:04Z
Image Repository:	image-registry.openshift-image-registry.svc:5000/openshift/driver-toolkit
Image Lookup:		local=false
Unique Images:		1
Tags:			2

latest
  updates automatically from registry quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:c59694c1e00d4d9f85fcf3c8515a8553ae304535e78a4cf72ca973d508c0ba0b

  * quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:c59694c1e00d4d9f85fcf3c8515a8553ae304535e78a4cf72ca973d508c0ba0b
      2 hours ago

48.84.202110152059-0
  updates automatically from registry quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:c59694c1e00d4d9f85fcf3c8515a8553ae304535e78a4cf72ca973d508c0ba0b

  * quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:c59694c1e00d4d9f85fcf3c8515a8553ae304535e78a4cf72ca973d508c0ba0b
      2 hours ago

# oc debug node/<worker_node>:
Starting pod/<worker_node>internal-debug ...
To use host binaries, run `chroot /host`
chroot /host
Pod IP: 10.0.128.2
If you don't see a command prompt, try pressing enter.
sh-4.4# chroot /host
sh-4.4# cat /etc/release
cat: /etc/release: No such file or directory
sh-4.4# cat /etc/os-release
NAME="Red Hat Enterprise Linux CoreOS"
VERSION="48.84.202110152059-0"
ID="rhcos"
ID_LIKE="rhel fedora"
VERSION_ID="4.8"
PLATFORM_ID="platform:el8"
PRETTY_NAME="Red Hat Enterprise Linux CoreOS 48.84.202110152059-0 (Ootpa)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:8::coreos"
HOME_URL="https://www.redhat.com/"
DOCUMENTATION_URL="https://docs.openshift.com/container-platform/4.8/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="OpenShift Container Platform"
REDHAT_BUGZILLA_PRODUCT_VERSION="4.8"
REDHAT_SUPPORT_PRODUCT="OpenShift Container Platform"
REDHAT_SUPPORT_PRODUCT_VERSION="4.8"
OPENSHIFT_VERSION="4.8"
RHEL_VERSION="8.4"
OSTREE_VERSION='48.84.202110152059-0'
sh-4.4# exit
exit
sh-4.4# exit
exit

Removing debug pod ...

# oc describe is -n openshift driver-toolkit | grep "48.84.202110152059-0"
48.84.202110152059-0

Comment 7 errata-xmlrpc 2021-10-27 08:15:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.17 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3927

Comment 8 dagray 2021-10-29 20:43:44 UTC
*** Bug 2011024 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.