Bug 201150 - Insertion of CD doesn't result in autoplay/autorun application being run
Insertion of CD doesn't result in autoplay/autorun application being run
Status: CLOSED DUPLICATE of bug 201533
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 04:34 EDT by Graeme Coates
Modified: 2013-03-13 00:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 08:03:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Graeme Coates 2006-08-03 04:34:11 EDT
Description of problem:

When inserting a CD (using a Freecom USB CDRW drive) , the selected application
(through "Removeable Drives and Media" frontend to gnome-volume-manager) doesn't
appear to run. This is observed to fail with audio CDs (where I would expect
totem to run), blank data CDs (with relevant setting turned on), and data CDs
(eg FC5 CD1) where I would expect the media to be mounted and then to have a
nautilus browser windows appear.

This works under the stock FC5 distribution but breaks when updates are applied
(though not due to the kernel upgrade alone - running just a kernel update
doesn't stop this working). 


Version-Release number of selected component (if applicable):

1.5.15

How reproducible:

Always.

Steps to Reproduce:
1. Install FC5 from CD.
2. In GNOME, insert audio CD - totem plays CD as expected
3. Run `yum update -y` to update system to latest patch level.
4. Reboot as prompted
5. Return to GNOME desktop, insert any CD - CD does not autoplay as expected
(check in "Removeable Drives and Media" that settings are unchanged and would
expect CD to autorun).
  
Actual results:

CD doesn't autorun.

Expected results:

CD plays according to settings in "Removeable Drives and Media".

Additional info:

Results of uname -a:

Linux localhost.localdomain 2.6.17-1.2157_FC5 #1 Tue Jul 11 22:55:46 EDT 2006
i686 athlon i386 GNU/Linux

Results of /sbin/lsmod:

Module                  Size  Used by
autofs4                21701  1
hidp                   16833  2
rfcomm                 37333  0
l2cap                  23873  10 hidp,rfcomm
bluetooth              47909  5 hidp,rfcomm,l2cap
sunrpc                157309  1
ip_conntrack_netbios_ns     3265  0
ipt_REJECT              5569  1
xt_state                2497  2
ip_conntrack           52597  2 ip_conntrack_netbios_ns,xt_state
nfnetlink               7257  1 ip_conntrack
xt_tcpudp               3393  4
iptable_filter          3265  1
ip_tables              12809  1 iptable_filter
x_tables               14917  4 ipt_REJECT,xt_state,xt_tcpudp,ip_tables
video                  16709  0
button                  6993  0
battery                10053  0
ac                      5189  0
sr_mod                 17637  0
ipv6                  243169  14
lp                     12937  0
parport_pc             27237  1
parport                37129  2 lp,parport_pc
usb_storage            69153  0
floppy                 58437  0
ehci_hcd               32461  0
st                     37597  0
sg                     34525  0
uhci_hcd               23885  0
snd_cmipci             34913  1
gameport               16201  1 snd_cmipci
snd_seq_dummy           4165  0
snd_seq_oss            32705  0
snd_seq_midi_event      7745  1 snd_seq_oss
snd_seq                53553  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            40017  0
snd_mixer_oss          17729  1 snd_pcm_oss
snd_pcm                83781  2 snd_cmipci,snd_pcm_oss
snd_page_alloc         10569  1 snd_pcm
snd_opl3_lib           10817  1 snd_cmipci
snd_timer              24517  3 snd_seq,snd_pcm,snd_opl3_lib
snd_hwdep              10053  1 snd_opl3_lib
snd_mpu401_uart         8769  1 snd_cmipci
snd_rawmidi            25665  1 snd_mpu401_uart
snd_seq_device          9037  5 snd_seq_dummy,snd_seq_oss,snd_seq,snd_opl3_lib,s
nd_rawmidi
snd                    55237  14 snd_cmipci,snd_seq_oss,snd_seq,snd_pcm_oss,snd_
mixer_oss,snd_pcm,snd_opl3_lib,snd_timer,snd_hwdep,snd_mpu401_uart,snd_rawmidi,s
nd_seq_device
soundcore              10017  1 snd
i2c_viapro              8789  0
i2c_core               22209  1 i2c_viapro
via_ircc               21461  0
irda                  115449  1 via_ircc
crc_ccitt               2369  1 irda
tulip                  49761  0
dm_snapshot            18285  0
dm_zero                 2241  0
dm_mirror              22673  0
dm_mod                 59225  5 dm_snapshot,dm_zero,dm_mirror
ext3                  129097  3
jbd                    57813  1 ext3
sata_promise           12101  0
libata                 68049  1 sata_promise
aic7xxx               138229  0
scsi_transport_spi     24897  1 aic7xxx
sd_mod                 20417  0
scsi_mod              135657  8 sr_mod,usb_storage,st,sg,libata,aic7xxx,scsi_tra
nsport_spi,sd_mod
Comment 1 John (J5) Palmieri 2006-08-03 16:00:23 EDT
What version of HAL do you have installed.  Can you try with the latest from
Rawhide (please reboot after updating).
Comment 2 Graeme Coates 2006-08-06 08:15:40 EDT
`rpm -qa | grep hal` gives:

hal-gnome-0.5.7.1-2.fc5
hal-0.5.7.1-2.fc5
hal-cups-utils-0.5.5-1.2.fc5.2


Trying the latest Rawhide hal probably isn't viable for me at present
(dependencies mean it'll take a lot of my box to Rawhide which is not what I
want to do). Will see if it's possble to replicate in another way (may try a VM
or something to see if it'll work that way).
Comment 3 Graeme Coates 2006-08-17 08:03:09 EDT
I think this is the same as Bug 201533 as manifested for USB CD drives - lshal
has no storage.cdrom entries for this device.

*** This bug has been marked as a duplicate of 201533 ***

Note You need to log in before you can comment on or make changes to this bug.