Bug 201155 - The Application "evolution-2.8" has quit unexpectedly.
The Application "evolution-2.8" has quit unexpectedly.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgnomeprintui22 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 04:59 EDT by Xiaohong Wang
Modified: 2013-03-13 00:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: libgnomeprintui22-2.12.1-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 17:46:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (43.71 KB, image/png)
2006-08-03 04:59 EDT, Xiaohong Wang
no flags Details
Bug Buddy Backtrace (70.98 KB, text/plain)
2006-08-24 00:06 EDT, Matthew Barnes
no flags Details

  None (edit)
Description Xiaohong Wang 2006-08-03 04:59:53 EDT
Description of problem:


Version-Release number of selected component (if applicable):
evolution-2.7.4-4

How reproducible:
always

Steps to Reproduce:
1. Run evolution in the terminal (Evolution launches)
2. Select File -> Print Preview 
3. Click 'Show multiple pages' button and select 2x2
4. Click 'Edit' button
  
Actual results:
An error dialog pops up
---------------------------
The Application "evolution-2.8" has quit unexpectedly.

You can inform the developers of what happened to help them
fix it. Or you can restart the application right now.

Restart Application       Close          Inform Developers
---------------------------

Expected results:


Additional info:
Comment 1 Xiaohong Wang 2006-08-03 04:59:54 EDT
Created attachment 133541 [details]
screenshot
Comment 2 Matthew Barnes 2006-08-09 00:47:08 EDT
Unable to reproduce crash using Evolution 2.7.91.  I did, however, notice quite
a few GnomeCanvas-CRITICAL warnings when after I selected "Show multiple pages".

Can you try updating to the latest Evolution release and posting whether or not
you are still seeing this behavior?
Comment 3 Xiaohong Wang 2006-08-13 21:52:38 EDT
I verified on evolution-2.7.91-2, this bug still exits.

Steps to Reproduce:
1. Launche Contacts/Evolution/Tasks/Memos-Evolution
2. Select File -> Print Preview (Print Preview Window launches)
3. Click 'Show multiple pages' button and select 2x2 on Print Preview Window
4. Click 'Edit' button next to 'Show multiple pages'

thx
Comment 4 Matthew Barnes 2006-08-24 00:06:48 EDT
Created attachment 134771 [details]
Bug Buddy Backtrace

I must've been doing something wrong before because I am able to reproduce this
now with evolution-2.7.92-4.fc6.  Posting backtrace from Bug Buddy.
Comment 5 Matthew Barnes 2006-08-24 15:17:10 EDT
I have traced this crash to a bug in libgnomeprintui22.

In gnome-print-job-preview.c:gnome_print_job_preview_nx_and_ny_changed(), p is
declared as a GnomePrintJobPreviewPage (a struct, not a pointer).  p.n is never
getting initialized, and so a garbage p.n value is slipping in at the line:

    g_array_append_val (jp->pages, p)  /* becomes item [1] in the array */

This causes a crash later on when we try to execute the following in
gnome-print-job-preview.c:gnome_print_job_preview_selection_changed():

    p = g_array_index (jp->pages, GnomePrintJobPreviewPage, i)  /* i == 1 */
    ...
    g_array_index (jp->selection, gboolean, p.n)

Fortunately this has been fixed upstream in what will become 2.12.2.

The patch that fixes it is here:
http://cvs.gnome.org/viewcvs/libgnomeprintui/libgnomeprintui/gnome-print-job-preview.c?r1=1.91&r2=1.92
Comment 6 Matthew Barnes 2006-08-24 17:46:06 EDT
Backporting the portion of the upstream patch that initializes p.n seems to have
fixed the reported crashes.

Fixed in libgnomeprintui22-2.12.1-6

Note You need to log in before you can comment on or make changes to this bug.