Bug 201167 - hp920c doesn't work any more with latest cups
hp920c doesn't work any more with latest cups
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 06:50 EDT by Thorsten Scherf
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.3-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-30 12:11:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cups error_log (111.50 KB, application/octet-stream)
2006-08-15 09:11 EDT, Thorsten Scherf
no flags Details

  None (edit)
Description Thorsten Scherf 2006-08-03 06:50:50 EDT
Description of problem:
after configuring a remote ipp printer with the recommended driver (hp920c) it
just see this printed out:

-12345X@PJL ENTER LANGUAGE=PCL3
17H10 [...]


Version-Release number of selected component (if applicable):
cups-1.2.2-6

How reproducible:
generate a print job

Steps to Reproduce:
1.generate a print job
2.
3.
  
Actual results:
see above

Expected results:
a correctly printed page :)

Additional info:
local printing works without any problems, same printer works also without any
problems in fc5
Comment 1 Tim Waugh 2006-08-03 09:36:47 EDT
Possibly same as bug #200624.
Comment 2 Tim Waugh 2006-08-03 11:21:49 EDT
Isolated the problem and filed upstream:

  http://cups.org/str.php?L1881
Comment 3 Tim Waugh 2006-08-06 07:05:48 EDT
Please try cups-1.2.2-8.
Comment 4 Thorsten Scherf 2006-08-06 14:05:04 EDT
up to now, there is no cups-1.2.2-8 available in rawhide.
Comment 5 Tim Waugh 2006-08-07 04:39:41 EDT
I built it yesterday, at the time I posted comment #3.
Comment 7 Thorsten Scherf 2006-08-07 12:48:32 EDT
ok, will test it on Friday. actually I'm onsite and don't have access to me test
lab.



Comment 8 Thorsten Scherf 2006-08-10 08:45:06 EDT
still the same issues with cups-1.2.2-8
Comment 9 Tim Waugh 2006-08-11 07:53:11 EDT
How about cups-1.2.2-9?
Comment 10 Thorsten Scherf 2006-08-14 04:07:27 EDT
with latest rawhide 1.2.2-10 cups seems to be completely broken. no print job is
going out at all. this is my printers.conf:

# Printer configuration file for CUPS v1.2.2
# Written by cupsd on 2006-08-14 09:58
<DefaultPrinter printer>
Info HP920C
Location Office Dinslaken
DeviceURI ipp://192.168.0.50/printers/printer
State Stopped
StateMessage /usr/lib/cups/backend/ipp failed
StateTime 1155542325
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>

server port 631 is accessable:

[root@tiffy ~]# nmap -sS -p 631 192.168.0.50

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2006-08-14 10:14 CEST
Interesting ports on bert.example.com (192.168.0.50):
PORT    STATE SERVICE
631/tcp open  ipp
MAC Address: 00:05:5D:A3:33:CD (D-Link Systems)

but all generated jobs are still the the local queue. another strange thing
happened after installing latest rawhide: when I try to access the cups
webfrontend, I just get an "404 not found". strange, eh?



Comment 11 Tim Waugh 2006-08-15 08:03:39 EDT
If you run 'cupsenable thequeue' with the actual name of the queue instead of
'thequeue', does the queue start again?  If so, it's because there was some
error with a particular job and you have the error policy set to 'stop-printer'.

I haven't been able to reproduce the 404-not-found problem you describe.  Please
file a separate bug report for that problem so that we can analyze it further. 
Thanks.
Comment 12 Thorsten Scherf 2006-08-15 09:05:37 EDT
after cupsenable queuename, printer state changed to Idle, when then creating a
job, it stopped again. attached is the cups error_log.

[root@tiffy ~]# cat /var/log/cups/error_log
E [15/Aug/2006:15:12:31 +0200] Unknown directive debug2 on line 163.
I [15/Aug/2006:15:12:31 +0200] Polling cups.stuttgart.redhat.com:631
W [15/Aug/2006:15:12:31 +0200] "AuthClass System" is deprecated; consider using
"Require @SYSTEM" on line 838.
I [15/Aug/2006:15:12:31 +0200] Listening to 127.0.0.1:631 (IPv4)
I [15/Aug/2006:15:12:31 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [15/Aug/2006:15:12:31 +0200] Cleaning out old temporary files in
"/var/spool/cups/tmp"...
I [15/Aug/2006:15:12:31 +0200] Configured for up to 100 clients.
I [15/Aug/2006:15:12:31 +0200] Allowing up to 100 client connections per host.
I [15/Aug/2006:15:12:31 +0200] Creating CUPS default administrative policy:
I [15/Aug/2006:15:12:31 +0200] <Policy default>
I [15/Aug/2006:15:12:31 +0200] <Limit Send-Document Send-URI Cancel-Job Hold-Job
Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription
Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job
Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job
CUPS-Authenticate-Job>
I [15/Aug/2006:15:12:31 +0200] Order Deny,Allow
I [15/Aug/2006:15:12:31 +0200] Require user @OWNER @SYSTEM
I [15/Aug/2006:15:12:31 +0200] </Limit>
I [15/Aug/2006:15:12:31 +0200] <Limit Pause-Printer Resume-Printer
Set-Printer-Attributes Enable-Printer Disable-Printer
Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs
Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer
Startup-Printer Promote-Job Schedule-Job-After CUPS-Add-Printer
CUPS-Delete-Printer CUPS-Add-Class CUPS-Delete-Class CUPS-Accept-Jobs
CUPS-Reject-Jobs CUPS-Set-Default>
I [15/Aug/2006:15:12:31 +0200] Order Deny,Allow
I [15/Aug/2006:15:12:31 +0200] AuthType Basic
I [15/Aug/2006:15:12:31 +0200] Require user @SYSTEM
I [15/Aug/2006:15:12:31 +0200] </Limit>
I [15/Aug/2006:15:12:31 +0200] <Limit All>
I [15/Aug/2006:15:12:31 +0200] Order Deny,Allow
I [15/Aug/2006:15:12:31 +0200] </Limit>
I [15/Aug/2006:15:12:31 +0200] </Policy>
I [15/Aug/2006:15:12:31 +0200] Full reload is required.
I [15/Aug/2006:15:12:31 +0200] Loaded MIME database from '/etc/cups': 33 types,
38 filters...
I [15/Aug/2006:15:12:31 +0200] Loading job cache file "/var/cache/cups/job.cache"...
I [15/Aug/2006:15:12:31 +0200] Full reload complete.
I [15/Aug/2006:15:12:31 +0200] Listening to 127.0.0.1:631 on fd 3...
E [15/Aug/2006:15:12:31 +0200] Unable to set ACLs on root certificate
"/var/run/cups/certs/0" - Operation not supported
E [15/Aug/2006:15:12:41 +0200] cupsdAcceptClient: skipping getpeercon()
E [15/Aug/2006:15:12:41 +0200] cupsdAcceptClient: skipping getpeercon()
I [15/Aug/2006:15:12:41 +0200] Saving printers.conf...
I [15/Aug/2006:15:12:41 +0200] Printer "printer" started by "root".
E [15/Aug/2006:15:12:59 +0200] cupsdAcceptClient: skipping getpeercon()
E [15/Aug/2006:15:12:59 +0200] cupsdAcceptClient: skipping getpeercon()
I [15/Aug/2006:15:12:59 +0200] Adding start banner page "none" to job 96.
I [15/Aug/2006:15:12:59 +0200] Adding end banner page "none" to job 96.
I [15/Aug/2006:15:12:59 +0200] Job 96 queued on "printer" by "root".
I [15/Aug/2006:15:12:59 +0200] Started filter /usr/lib/cups/filter/texttopaps
(PID 9578) for job 96.
I [15/Aug/2006:15:12:59 +0200] Started filter /usr/lib/cups/filter/pstops (PID
9579) for job 96.
I [15/Aug/2006:15:12:59 +0200] Started filter /usr/lib/cups/filter/foomatic-rip
(PID 9580) for job 96.
I [15/Aug/2006:15:12:59 +0200] Started backend /usr/lib/cups/backend/ipp (PID
9581) for job 96.
E [15/Aug/2006:15:13:01 +0200] [Job 96] Print file was not accepted
(client-error-document-format-not-supported)!
E [15/Aug/2006:15:13:01 +0200] PID 9581 (/usr/lib/cups/backend/ipp) stopped with
status 1!
I [15/Aug/2006:15:13:01 +0200] Hint: Try setting the LogLevel to "debug" to find
out more.
I [15/Aug/2006:15:13:01 +0200] [Job 96] Backend returned status 1 (failed)
I [15/Aug/2006:15:13:01 +0200] Saving printers.conf...
[root@tiffy ~]# 


Comment 13 Thorsten Scherf 2006-08-15 09:11:23 EDT
Created attachment 134208 [details]
cups error_log
Comment 14 W. Michael Petullo 2006-08-20 15:54:44 EDT
I have a similar problem with cups-1.2.2-13.  Everything worked fine until I
upgraded.  When I print using a Brother HL-1440 driver, the following is printed:

-12345X@PJL
@PJL JOB NAME="Ghost"
@PJL SET ECONOMODE=OFF
@PJL SET MEDIATYPE=REGULAR
@PJL SET SOURCETRAY=AUTO
@PJL SET RESOLUTION=600
@PJL SET RAS1200MODE=ON
@PJL ENTER LANGUAGE=PCL
12Au1200D10o010E11XrBp0x0Yt600Rr1Ab1027Mb1613WK@s r

The generic PostScript driver works fine.
Comment 15 Tim Waugh 2006-08-21 05:45:08 EDT
redhat@flyn.org: what did you upgrade from? i.e. what is the last known good n-v-r?
Comment 16 W. Michael Petullo 2006-08-21 17:57:22 EDT
cups-1.2.1-14 worked fine with the Foomatic/hl1250 driver.
Comment 17 Tim Waugh 2006-08-22 13:02:47 EDT
cups-1.2.2-13 contains a regression from 1.2.2-12.  The difference is I switched
to the upstream patch.  I've posted a report about this regression here:

  http://cups.org/str.php?L1881
Comment 18 W. Michael Petullo 2006-09-01 14:44:02 EDT
Confirmed fixed for my situation.

Note You need to log in before you can comment on or make changes to this bug.