Bug 201168 - random crashes when weird characters are input
random crashes when weird characters are input
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 06:58 EDT by John Smith
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: f7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 21:44:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Smith 2006-08-03 06:58:26 EDT
This is the same bug as 190749, which I can't reopen.

Using rxvt-unicode-7.8-1.fc5 on an up to date FC5.

I get random crashes of urxvt, for instance when I do this:

1. Launch /usr/bin/urxvt
2. Press Ctrl, press Shift, release Shift, release Ctrl (so you are now in
"keycap  picture insert mode").
3. Press Caps Lock.

Depending on the phase of the moon, the above procedure can be harmless or it
can make urxvt crash in an almost completely reproducible manner.

Stack trace:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208453424 (LWP 25316)]
0x4b513e26 in FcFontSetSortDestroy () from /usr/lib/libfontconfig.so.1
(gdb) bt
#0  0x4b513e26 in FcFontSetSortDestroy () from /usr/lib/libfontconfig.so.1
#1  0x4b514abf in FcFontSetMatch () from /usr/lib/libfontconfig.so.1
#2  0x4b515476 in FcFontMatch () from /usr/lib/libfontconfig.so.1
#3  0x4ef1f110 in XftFontMatch () from /usr/lib/libXft.so.2
#4  0x08062edd in rxvt_font_xft::load ()
#5  0x080629f3 in rxvt_fontset::realize_font ()
#6  0x0806520c in rxvt_fontset::find_font ()
#7  0x0807557c in rxvt_term::scr_add_lines ()
#8  0x08061700 in rxvt_term::cmd_parse ()
#9  0x08061b04 in rxvt_term::pty_cb ()
#10 0x0808030b in io_manager::loop ()
#11 0x0805b4d9 in main ()

Using "LANG=en_US.UTF-8".

Also happens with urxvtc/urxvtd, in which case urxvtd crashes (and therefore all
urxvtc also crash).
Comment 1 Andreas Bierfert 2006-08-12 05:16:53 EDT
Does this happen with 7.9 as well? Cannot reproduce with 7.8 nor 7.9
Comment 2 John Smith 2006-08-14 19:42:32 EDT
I can reproduce it with 7.9 as well.  Same backtrace.  It looks like a bug in
libfontconfig.
Comment 3 Andreas Bierfert 2006-11-03 19:09:53 EST
how about 8.0? =)
Comment 4 John Smith 2006-11-08 20:16:33 EST
Just tried with rxvt-unicode-8.0-1.fc5.  Same crash.  Backtrace:

#0  0x43dbbe26 in FcFontSetSortDestroy () from /usr/lib/libfontconfig.so.1
#1  0x43dbcabf in FcFontSetMatch () from /usr/lib/libfontconfig.so.1
#2  0x43dbd476 in FcFontMatch () from /usr/lib/libfontconfig.so.1
#3  0x44613110 in XftFontMatch () from /usr/lib/libXft.so.2
#4  0x08062f34 in rxvt_font_xft::load ()
#5  0x08062a4b in rxvt_fontset::realize_font ()
#6  0x0806524c in rxvt_fontset::find_font ()
#7  0x080755ec in rxvt_term::scr_add_lines ()
#8  0x08061750 in rxvt_term::cmd_parse ()
#9  0x08061b54 in rxvt_term::pty_cb ()
#10 0x0808039b in io_manager::loop ()
#11 0x0805b519 in main ()

Some time ago the author told me he had encountered the problem and determined
that it was a bug in the version of libfontconfig that FC uses.
Comment 5 Andreas Bierfert 2006-11-09 07:05:05 EST
Hm then I am reassigning to fontconfig owner..
Comment 6 Behdad Esfahbod 2007-10-25 21:44:35 EDT
Fixed in the mean time I belive.

Note You need to log in before you can comment on or make changes to this bug.