Bug 2011774 - Toggled repos in Discover jump to the bottom of the list
Summary: Toggled repos in Discover jump to the bottom of the list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-discover
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://ask.fedoraproject.org/t/we-ar...
Depends On:
Blocks: F35FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-10-07 10:55 UTC by Kamil Páral
Modified: 2021-12-03 01:11 UTC (History)
6 users (show)

Fixed In Version: plasma-discover-5.23.2-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-16 16:34:43 UTC
Type: Bug


Attachments (Terms of Use)
repo jump and redraw issue (video) (1.75 MB, video/webm)
2021-10-07 10:57 UTC, Kamil Páral
no flags Details
rpm -qa (60.96 KB, text/plain)
2021-10-07 10:57 UTC, Kamil Páral
no flags Details


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 443583 0 NOR UNCONFIRMED Toggled repos in Discover jump to the bottom of the list, and other repo names are changed to undefined 2021-10-11 09:14:18 UTC

Description Kamil Páral 2021-10-07 10:55:43 UTC
Description of problem:
With plasma-discover-5.22.90-3.fc35, repo configuration suffers from redrawing issues and confusing item reordering. If you enable/disable any repo in the "Fedora Linux 35" section, that repo, together will all other repos defined in that same file, is moved to the very bottom of the list (so e.g. "F35 Updates + Updates Debug + Updates Source" are moved to the bottom). If you don't pay close attention to this, you might get confused. For example if the 'updates' triplet jumps away and on the same place appears the 'fedora' triplet with the same selection as originally (the first item enabled, the other two disabled), you might not re-read the item again carefully and just assume that your click wasn't registered, and click again (and then it disappears from the view and you'll not realize you've just disabled the 'fedora' repo).

Additionally, each time you perform the change, all items in the "Firmware Updates" and "Flatpak" sections get renamed to "undefined". For some items, scrolling up and down is enough the redraw them into proper names, for other items, you need to change the current tab to some other one and back.

See the attached video.

Version-Release number of selected component (if applicable):
plasma-discover-5.22.90-3.fc35 

How reproducible:
always

Steps to Reproduce:
1. go to Discover -> Settings
2. click an RPM repo to enable/disable it
3. see the repo (and related ones) disappear, find them at the bottom
4. see other items in other sections renamed to "undefined"

Comment 1 Kamil Páral 2021-10-07 10:57:17 UTC
Created attachment 1830328 [details]
repo jump and redraw issue (video)

Comment 2 Kamil Páral 2021-10-07 10:57:22 UTC
Created attachment 1830329 [details]
rpm -qa

Comment 3 Rex Dieter 2021-10-07 14:22:46 UTC
Please report upstream.

I saw the undefinted thing too, but appeared to be temporary while config is re-read.

Comment 4 Kamil Páral 2021-10-11 08:42:47 UTC
Tested with plasma-discover-5.23.0-1.fc35 and the bug is still there. Please note that the reshuffled rpm repo order survives reboots, i.e. the order change is permanent. The "undefined" glitch is temporary, until the page is forced to be redrawn.

Comment 5 Kamil Páral 2021-10-11 09:14:19 UTC
Upstream bug report: https://bugs.kde.org/show_bug.cgi?id=443583

Comment 6 Kamil Páral 2021-10-11 09:19:59 UTC
Since bug 2011305 is an accepted blocker now, and the proposed update for it [1] introduces/uncovers this bug, I'm going to mark this for a blocker discussion as well. It's not fully technically correct (this bug can't be a blocker before that update is pushed stable), but a) I want others to be aware of it, and b) it's very likely that this bug has been already present in Discover for some time, it just couldn't be tested due to bug 2011305.

[1] https://bodhi.fedoraproject.org/updates/FEDORA-2021-a32a5c05d4

Comment 7 Geoffrey Marr 2021-10-11 19:06:50 UTC
Discussed during the 2021-10-11 blocker review meeting: [0]

The decision to classify this bug as a "RejectedBlocker (Final)" and an "AcceptedFreezeException (Final)" was made as we agreed that while this looks bad, the operation does work, so critical functionality is maintained. It's accepted as an FE issue if it can be fixed relatively safely, as it does look pretty bad.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2021-10-11/f35-blocker-review.2021-10-11-16.00.txt

Comment 8 Fedora Update System 2021-10-18 19:51:14 UTC
FEDORA-2021-4f68774f07 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4f68774f07

Comment 9 Adam Williamson 2021-10-18 19:52:23 UTC
https://bodhi.fedoraproject.org/updates/FEDORA-2021-4f68774f07 should fix the "other repos go to 'undefined'" part of this. It doesn't solve the order changing part, though. Aleix is working on a bigger fix that would avoid the whole "refresh the entire interface whenever you touch a PK repo" thing, but we don't think that's likely safe to rush in for Final.

Comment 10 Geraldo Simião 2021-10-18 20:22:53 UTC
Tested it and just like @awilliam@redhat.com said: no more the "undefined" problem, thats fixed.

Comment 11 Adam Williamson 2021-10-18 23:18:20 UTC
https://invent.kde.org/plasma/discover/-/merge_requests/192 is the PR that would address the rest of this, probably.

Comment 12 Kamil Páral 2021-10-19 07:09:33 UTC
(In reply to Geraldo Simião from comment #10)
> Tested it and just like @awilliam@redhat.com said: no more the "undefined"
> problem, thats fixed.

Confirmed.

Comment 13 Fedora Update System 2021-10-20 13:47:38 UTC
FEDORA-2021-4f68774f07 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4f68774f07`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4f68774f07

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2021-10-21 00:55:13 UTC
FEDORA-2021-4f68774f07 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Kamil Páral 2021-10-21 07:05:00 UTC
The remaining issue is that the toggled repos jump around in the list.

Comment 16 Adam Williamson 2021-10-21 22:11:11 UTC
https://koji.fedoraproject.org/koji/taskinfo?taskID=77634062 is a scratch build with the fix for this. Please test it quite hard as it changes the logic of how the PK source list gets refreshed, so see if you can break that...enable and disable a bunch of sources, add sources, remove them, leave and re-enter the page, stuff like that.

Comment 17 Kamil Páral 2021-10-25 11:41:36 UTC
Adam, the repo jumping is fixed. I only found one problem in my testing. If you quickly click twice on a repo checkbox, you can make it not reflect the actual state. So e.g. if updates-testing is disabled (unchecked), and you quickly click twice on its checkbox, it gets checked and unchecked again, i.e. it looks as disabled. But in fact, only the first action got performed in the code beneath, and updates-testing is currently enabled. Switching the tab to e.g. About and back to Settings redraws the checkbox into a proper (checked) state.

I'm not able to verify whether this is a new bug or it existed before, because it couldn't be triggered before (the repos jumped around, and if you tried this with the bottom-most repo, the whole page scrolled up, preventing you from doing a double click).

Comment 18 Adam Williamson 2021-10-25 19:47:10 UTC
thanks. yeah, I've managed to trigger bugs in the other backends by doing the same thing, but it strikes me as a fairly unlikely 'real world' thing, it's more something you and me would do because we like breaking stuff. :P So if that's the only problem, I think the fix is good, but...on the whole, since it's Monday, it might be best to hold off pulling the fix into the final compose. I think I'll submit it but leave it to be a 0-day update.

Comment 19 Fedora Update System 2021-10-28 18:48:31 UTC
FEDORA-2021-35e9884fd8 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-35e9884fd8

Comment 20 Fedora Update System 2021-11-04 14:08:09 UTC
FEDORA-2021-f7d19c8901 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-f7d19c8901`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-f7d19c8901

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Geraldo Simião 2021-11-04 20:21:40 UTC
seems to be fixed here after the update https://bodhi.fedoraproject.org/updates/FEDORA-2021-f7d19c8901

Comment 22 Fedora Update System 2021-11-16 16:34:43 UTC
FEDORA-2021-f7d19c8901 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.