Bug 201213 - None of the installed openoffice.org applications will launch
None of the installed openoffice.org applications will launch
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 12:39 EDT by James Crocker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-26 10:30:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Crocker 2006-08-03 12:39:54 EDT
Description of problem:

None of the installed openoffice.org applications will startup|launch.
oodraw     ooffice    ooimpress  oomath     ooviewdoc  oowriter

Version-Release number of selected component (if applicable):

openoffice.org-calc-2.0.2-5.16.2
openoffice.org-core-2.0.2-5.16.2
openoffice.org-draw-2.0.2-5.16.2
openoffice.org-graphicfilter-2.0.2-5.16.2
openoffice.org-impress-2.0.2-5.16.2
openoffice.org-math-2.0.2-5.16.2
openoffice.org-writer-2.0.2-5.16.2
openoffice.org-xsltfilter-2.0.2-5.16.2

How reproducible:

Always


Steps to Reproduce:
1. From command line >oocalc (etc.)
2. From Gnome->Applications->Office->Calc (etc.)
  
Actual results:

From the command line no error messages. Nothing in /var/log/messages or
otherwise. From the Gnome menuing nothing returns.

Expected results:

Application startup|launch.

Additional info:

Linux 2.6.17-1.2157_FC5 #1 SMP x86_64 x86_64 x86_64 GNU/Linux
Gnome w/ Fedora BlueCurve

Perfomed the GL Test:
-bash-3.1# gcc testgl.c -o testgl -L/usr/X11R6/lib -lX11 -lGL
-bash-3.1# ./testgl
All OK

FireFox OK.

GLXGears: 
-bash-3.1# glxgears
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  78 (X_CreateColormap)
  Value in failed request:  0x0
  Serial number of failed request:  14
  Current serial number in output stream:  22

GDB:
-bash-3.1# gdb /usr/lib/openoffice.org2.0/program/soffice.bin
GNU gdb Red Hat Linux (6.3.0.0-1.122rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".
(gdb)run -writer
<no debugging symbols found>
Program exited with code 0116.
Comment 1 Paul F. Johnson 2006-08-03 18:51:26 EDT
This may be the same problem as I'm seeing (although I'm on OOo-2.0.3.7-7)

When I start OOo-writer, I get

/usr/lib64/openoffice.org2.0/program/soffice: line 147: 18519 Segmentation fault
"$sd_prog/$sd_binary" "$@"
Comment 2 Caolan McNamara 2006-08-04 04:11:43 EDT
caolanm->paul: you are on rawhide, and probably bitten by glibc bug 200635 which
is an actual SEGV crash.

caolanm->james: you are on fc-5, and when you run it from a command line, or
from gdb it doesn't seem to actually crash, (though your glxgears output is
troubling) but appears to "do nothing". Perhaps OOo thinks that another copy of
itself is running and thinks it has told the other copy to open a new window
successfully so...

1. make sure there are no copies running
ps xw | grep openoffice
and kill off any that might be running
2. then rm -rf /tmp/OSL_PIPE_*
to remove any possible stale openoffice.org pipes that are still around

If that fails to work, can you paste the output from /usr/sbin/sestatus here, in
case it is relevant
Comment 3 James Crocker 2006-08-04 12:01:13 EDT
I've yum'd the installation and upgraded the openoffice.org packages to 
version: 2.0.2-5.17.2 

>ps -ef | grep -i office
> nada

There were OSL_PIPE* pipes in /tmp. I removed them and attempted to launch any 
of the oo* applications. The re-launch of the openoffice apps recreated an 
OSL_PIPE entry in /tmp. But same behavior as before... nothing.

SELinux is disabled.
Comment 4 James Crocker 2006-08-25 14:25:26 EDT
FIXED:

The problem was that the OO was needing the libXp *i386* rpm version 
installed. Once in place everything is operational.
Comment 5 Caolan McNamara 2006-08-26 10:30:12 EDT
Excellent work, I thought it would be something like that, clearly for the
native x86_64 OOo in FC-6 this isn't relevent, but I'll add a explicit require
to the FC-5 package on the .so provided by that libXp i386 package so if we
update OOO for FC-5 again we'll pick up on this.

Note You need to log in before you can comment on or make changes to this bug.