Bug 201219 - E1000 module kernel panics during stress test
E1000 module kernel panics during stress test
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 13:08 EDT by Sarah Prelutsky
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 23:02:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg (20.03 KB, text/plain)
2006-08-03 13:08 EDT, Sarah Prelutsky
no flags Details
Nic stress test script (1.01 KB, text/plain)
2006-08-03 13:09 EDT, Sarah Prelutsky
no flags Details
Lspci -v (13.63 KB, text/plain)
2006-08-03 13:35 EDT, Sarah Prelutsky
no flags Details

  None (edit)
Description Sarah Prelutsky 2006-08-03 13:08:13 EDT
Description of problem: E1000 module kernel panics during stress test


Version-Release number of selected component (if applicable):


How reproducible:
Everytime

Steps to Reproduce:
1. connect crossover to both nic ports (onboard)
2. run burneth script (will attach this to bug)
3. kernel panic
  
Actual results:

After running our stress test the script hangs up when it is renegotiating the
duplex and kernel panics

Expected results:

The machine should not kernel panic.


Additional info: Attached is the dmesg and the stress test script.
Comment 1 Sarah Prelutsky 2006-08-03 13:08:13 EDT
Created attachment 133565 [details]
Dmesg
Comment 2 Sarah Prelutsky 2006-08-03 13:09:43 EDT
Created attachment 133566 [details]
Nic stress test script
Comment 3 Sarah Prelutsky 2006-08-03 13:35:23 EDT
Created attachment 133568 [details]
Lspci -v
Comment 4 Sarah Prelutsky 2006-08-04 13:51:17 EDT
Today i got a chance to try fc6test1 and I encountered the same kernel panic.
This time due to the lockdep feature in the new kernel i got a ver nice verbose
output that i feel would help out this bug to.

Bugzilla: 201374 

Comment 5 John W. Linville 2006-08-04 16:32:39 EDT
Test kernels w/ e1000 7.1.9-k4 are available here:

   http://people.redhat.com/linville/kernels/rhel4/

Please give those a try and post the result here...thanks!
Comment 6 Sarah Prelutsky 2006-08-08 13:01:42 EDT
During a 24hour hour test period I experienced no kernel panics. I did however
loose 1 of the 2 interfaces sometime between hour 7 and hour 24. I have looked
thru /var/log/messages and have not seen anything to say why it was no longer
configuring an ip on eth0. I had no errors or anything else out of the ordinary
when I did ifconfig -a.

Is there any other data I could provide you from the system?
Comment 7 Sarah Prelutsky 2006-08-08 13:03:50 EDT
During a 24hour hour test period I experienced no kernel panics. I did however
loose 1 of the 2 interfaces sometime between hour 7 and hour 24. I have looked
thru /var/log/messages and have not seen anything to say why it was no longer
configuring an ip on eth0. I had no errors or anything else out of the ordinary
when I did ifconfig -a.

Is there any other data I could provide you from the system?
Comment 8 John W. Linville 2006-08-08 13:15:39 EDT
Can you bring-up eth0 manually now?  Or is it completely dead?
Comment 9 Sarah Prelutsky 2006-08-08 13:19:34 EDT
Yes it can be brought up manually, with dhclient or with the script. It is not
hard down.
Comment 10 Sarah Prelutsky 2006-08-09 19:21:26 EDT
Ran the stress test script overnight and this time in a 24hour period everything
worked fine. I belive someone may have mad some adjustments to the machine for
the first test cycle causeing the interface to drop. This time everything was great!
Comment 11 John W. Linville 2006-08-10 13:40:08 EDT
Hmmm...so does that imply that this issue is resolved?  Or that it never was a 
real issue?  Or...?
Comment 12 Sarah Prelutsky 2006-08-10 13:47:52 EDT
No this was/is a real problem. The 7.1.9-k4 e1000 drivers seem to do the trick.
This actually happens on Fedora 5.90 (Core 6 test 1) also.
Comment 13 RHEL Product and Program Management 2006-09-07 15:03:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 14 RHEL Product and Program Management 2006-09-07 15:03:55 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 17 Jason Baron 2006-12-04 14:10:49 EST
committed in stream U5 build 42.28. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 20 Red Hat Bugzilla 2007-05-07 23:02:26 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html

Note You need to log in before you can comment on or make changes to this bug.