Bug 2012244 - no included backgrounds
Summary: no included backgrounds
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: gnome-session
Version: CentOS Stream
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Tomas Pelka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-08 16:18 UTC by Alain Reguera Delgado
Modified: 2022-05-17 12:45 UTC (History)
8 users (show)

Fixed In Version: gnome-session-40.1.1-6.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-17 12:31:29 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
CentOS Stream 9 Workstation Without Background (9.76 KB, image/png)
2021-10-18 12:58 UTC, Alain Reguera Delgado
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-99312 0 None None None 2021-10-08 16:21:23 UTC
Red Hat Product Errata RHBA-2022:2329 0 None None None 2022-05-17 12:31:39 UTC

Description Alain Reguera Delgado 2021-10-08 16:18:02 UTC
Description of problem:

When you install the latest CentOS Stream distribution in its workstation variant, it doesn't provide the artwork created for it, but a black screen as wallpaper.

Version-Release number of selected component (if applicable):

90.0

How reproducible:

Always.

Steps to Reproduce:
1. Install http://mirror.stream.centos.org/9-stream/BaseOS/x86_64/iso/CentOS-Stream-9-latest-x86_64-dvd1.iso
2. Select Workstation Variant during the installation process.
3. Login

Actual results:

The desktop wallpaper is a plain black color. No artwork.


Expected results:

The desktop wallpaper shows the artistic motif created for it in https://github.com/CentOS/centos-logos/releases/tag/90.4.


Additional info:

None.

Comment 1 Alain Reguera Delgado 2021-10-15 16:25:33 UTC
The last compose (date 2021-10-14) already ships centos-logos-90.4. However, the /usr/share/backgrounds/ directory is still empty. Probably something in the package spec file?

Best regards.

Comment 2 Alain Reguera Delgado 2021-10-18 12:58:38 UTC
Created attachment 1834219 [details]
CentOS Stream 9 Workstation Without Background

Add screenshot for visual reference.

Comment 3 Carl George 🤠 2021-11-19 04:21:32 UTC
I believe the problem is that the backgrounds are part of the centos-backgrounds subpackage.  That is built [0], but it is not being installed by default when selecting "server with GUI" or "workstation" in the installer.  In fact I don't even see it in the repos, meaning it's not being included in the compose.

[0] https://kojihub.stream.centos.org/koji/buildinfo?buildID=14678

Comment 4 Neal Gompa 2021-11-19 04:39:21 UTC
We're also missing symlinks for default backgrounds so desktops will pick it up.

For example, the following file paths should be symlinks pointing to the correct files:

/usr/share/backgrounds/default.png
/usr/share/backgrounds/default.xml
/usr/share/backgrounds/images
/usr/share/backgrounds/images/default-16_10.png
/usr/share/backgrounds/images/default-16_9.png
/usr/share/backgrounds/images/default-5_4.png
/usr/share/backgrounds/images/default.png

Comment 5 Troy Dawson 2021-12-02 20:03:50 UTC
I just checked.  This is NOT a CentOS Stream problem. This is a RHEL 9 problem, that is also affecting CentOS Stream 9.

Comment 7 Ray Strode [halfline] 2021-12-02 20:35:33 UTC
I'm okay with adding a 

Recommends: system-backgrounds

to gnome-session.  devack+

Comment 14 errata-xmlrpc 2022-05-17 12:31:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (new packages: gnome-control-center), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:2329


Note You need to log in before you can comment on or make changes to this bug.