Bug 201235 - [RHEL5 alpha,beta1] anaconda: stall at the enablefilesystems step when trying multipath root installation.
[RHEL5 alpha,beta1] anaconda: stall at the enablefilesystems step when trying...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Mike McLean
pm-20060928
:
Depends On: 203424
Blocks: 179575
  Show dependency treegraph
 
Reported: 2006-08-03 14:32 EDT by Kiyoshi Ueda
Modified: 2007-11-30 17:07 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 13:58:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log files on the installer environment (13.67 KB, application/octet-stream)
2006-08-03 14:32 EDT, Kiyoshi Ueda
no flags Details
rawhide-20060830 anaconda exception (306.44 KB, application/octet-stream)
2006-08-31 12:21 EDT, Jun'ichi NOMURA
no flags Details
stall on rawhide 20060830 (console screenshot) (1.67 KB, text/plain)
2006-09-01 14:30 EDT, Jun'ichi NOMURA
no flags Details
traceback log (16.31 KB, text/plain)
2006-09-14 10:31 EDT, Kiyoshi Ueda
no flags Details

  None (edit)
Description Kiyoshi Ueda 2006-08-03 14:32:51 EDT
Description of problem:
This is a RHEL5 *ALPHA* bug.
Anaconda stalls at the enablefilesystems step when root filesystem
is assigned on top of a multipath device.


Version-Release number of selected component:
RHEL5-Server-20060802.0/4.91
anaconda-11.1.0.75-1


How reproducible:
Always


Steps to Reproduce:
 1. start anaconda
 2. assign root filesystem on top of a multipath device
 3. start installation after all settings for the installation are done


Actual results:
Anaconda stalls at the enablefilesystems step.
(See attached anaconda.log.)


Expected results:
Anaconda should not stall.


Additional info:
There are 4 multipath devices (mpath0/mpath1/mpath2/mpath3)
in the test environment.
Below is the information when anaconda stalls after I assign
the mpath1 as root filesystem by using auto partitioning feature:
  o Anaconda stalls at the enablefilesystems step. (see anaconda.log)
  o Anaconda is openning the mpath1. (see proc-pid-fd.log)
  o Partition table has been written. (see parted.log)
  o Lvm volumes are not created yet. (see lvmout and lvm.log)
  o Device maps of partitions which should be created by disk-druid
    at partitioning stage are not created yet. (see dmsetup.log)

I also tried using existing partition on a multipath device
as root filesystem, and the result was similer (anaconda stalled).
Comment 1 Kiyoshi Ueda 2006-08-03 14:32:52 EDT
Created attachment 133574 [details]
log files on the installer environment
Comment 2 Peter Jones 2006-08-04 10:01:09 EDT
Should work in the 20060804 tree.  Can you test?
Comment 3 Peter Jones 2006-08-04 10:07:27 EDT
... or maybe not, the new package didn't get pulled into the tree.  Will try to
make sure it gets pulled in for the next build.
Comment 4 Kiyoshi Ueda 2006-08-07 16:46:43 EDT
What version of anaconda is the fix included in?
11.1.0.78-1?
Comment 5 Kiyoshi Ueda 2006-08-11 17:19:32 EDT
I tried anaconda-11.1.0.77-1 in the RHEL5-Server-20060806.1 tree,
and I can still see the problem.

I also checked the changelog of anaconda-11.1.0.80-1, but I can't
find the fix after 11.1.0.77-1.
What version of anaconda is the fix included in?

---------------------------------------------------------------------
* Tue Aug 08 2006 Paul Nasrat <pnasrat@redhat.com> 11.1.0.80-1
- Blacklist e2fsprogs.ppc64 on upgrades (#200233)
- Set self.currentMedia to [] (dcantrel, #201722).
- Remove multiple error messages (dcantrel, #201247)
- Revert logMessage calls (clumens, #201707)

* Mon Aug 07 2006 Chris Lumens <clumens@redhat.com> 11.1.0.79-1
- s390 build fix.

* Mon Aug 07 2006 Chris Lumens <clumens@redhat.com> 11.1.0.78-1
- Fix password writing for interactive kickstart installs (#201455).
- Don't check percentage on preexisting LVs (#193341).
- Log added repos (#201212).
- Start adding things for ia64 Xen (katzj).
- Use new raid module name (katzj, #201361).
- Look for ifconfig in the right place during rescue mode (#201372).
- Fix segfault in FTP and HTTP path typos (#197403, #201243, #201367).
- Don't display the askmethod screen on CD installs (#201108).
- Do a better job at updating mkfs percentage bar (pjones).
- Fix finding the release notes (#201232).
- Add libvolume_id for gfs2-utils (katzj).
---------------------------------------------------------------------
Comment 6 Kiyoshi Ueda 2006-08-22 13:16:42 EDT
I tried anaconda-11.1.0.77-6 in the RHEL5-Server-20060818.3 tree,
and I can still see the problem.
Comment 7 Jun'ichi NOMURA 2006-08-31 12:19:03 EDT
RHEL5-Server-20060825.1 (anaconda-11.1.0.77-9) still has the same problem.

The problem occurs even when I don't use any partitions/LVs on multipath devices.
When I give 'nompath' boot option to the installer, the installation succeeds
but I cannot see dm-multipath devices.
Comment 8 Jun'ichi NOMURA 2006-08-31 12:21:02 EDT
Created attachment 135304 [details]
rawhide-20060830 anaconda exception

FYI, I also tried rawhide-ia64 (20060830).
Then the installer got exception instead of stalling.
    anaconda-11.1.0.86-1.ia64.rpm
    parted-1.7.1-15.fc6.ia64.rpm
    device-mapper-1.02.07-1.1.ia64.rpm
    device-mapper-multipath-0.4.7-4.0.ia64.rpm

Attached is a log of the exception.
Comment 9 Jun'ichi NOMURA 2006-09-01 14:30:32 EDT
Created attachment 135402 [details]
stall on rawhide 20060830 (console screenshot)

The exception reported in #8 occurred only once.
(I have removed all unnecessary LV/VGs on the system.
 It might have affected on it.)

Instead, with the same distribution rawhide 20060830,
I've seen another stall when it's installing kernel rpm.
This stall occurs 5 times out of 5 trials to install
on multipath device.
The stall didn't occur when the installation is done
to SCSI device.

The original stall still occurs on RHEL5-Server-20060830.1
(anaconda-11.1.0.77-9).
Comment 10 Jun'ichi NOMURA 2006-09-01 14:33:07 EDT
Peter,
RHEL5 pre-beta still cannot be installed when there is
multipath device.
rawhide seems a little bit better but it fails to install
on multipath device, too.

There is a following changelog between RHEL5 anaconda (11.1.0.77)
and rawhide anaconda (11.1.0.86):

+2006-08-21  Peter Jones  <pjones@redhat.com>
+
+       * isys/isys.py (driveDict): only return dm devices when "disk" is
+       the klassArg in question, but don't fall through to the 'elif' for
+       other klassArgs, either.

Does this explain the difference between RHEL5 and rawhide?
Comment 13 Andrius Benokraitis 2006-09-07 13:58:51 EDT
I'm assuming this is still an issue in RHEL 5 Beta 1, as well as the Alpha?
Comment 14 Jun'ichi NOMURA 2006-09-07 14:08:56 EDT
Yes.
Comment 16 Kiyoshi Ueda 2006-09-14 10:31:31 EDT
Created attachment 136264 [details]
traceback log

In the anaconda-11.1.0.77-11 of the RHEL5-Server-20060912.2,
traceback occurs around the enablefilesystems step if the machine
has multipath storages, even if the multipath storages aren't used.
(If 'nompath' boot option is given, this traceback doesn't occur.)

The traceback message from anaconda is attached.
Comment 17 Dave Wysochanski 2006-09-14 15:18:32 EDT
Netapp is also very interested in multipath root for RHEL5 so adding them to CC
list.
Comment 19 Peter Jones 2006-09-20 19:03:11 EDT
The traceback in comment #16 is a parted bug, and needs to be filed as such.  It
isn't a bug in the multipath support.
Comment 20 Peter Jones 2006-09-20 19:35:05 EDT
(in fact, comment #16 is bugzilla #203424 )
Comment 21 Andrius Benokraitis 2006-09-22 13:42:41 EDT
Adding EMC to this bug.
Comment 22 Kiyoshi Ueda 2006-10-03 13:58:32 EDT
I confirmed this bug is fixed in the anaconda-11.1.0.99-1.
So I close this bugzilla.

Note You need to log in before you can comment on or make changes to this bug.