Bug 20124 - gcc can't compile mysql on sparc
Summary: gcc can't compile mysql on sparc
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mysql   
(Show other bugs)
Version: 1.0
Hardware: sparc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Patrick Macdonald
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-31 21:40 UTC by Trond Eivind Glomsrxd
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-31 21:40:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2000:133 normal SHIPPED_LIVE Updated mysql packages available for Red Hat Linux 7 2000-12-19 05:00:00 UTC

Description Trond Eivind Glomsrxd 2000-10-31 21:40:21 UTC
gcc-2.96-62 can't compile mysql on SPARC, even with -O0 (and hasn't been
able to since egcs) - it boms out in the hash-generating part:

[sparc] c++ -O3 -DDBUG_OFF -O0 -fno-implicit-templates -rdynamic -o
gen_lex_hash gen_lex_hash.o ../isam/libnisam.a ../merge/libmerge.a
../myisam/libmyisam.a ../myisammrg/libmyisammrg.a ../heap/libheap.a
../mysys/libmysys.a ../dbug/libdbug.a ../regex/libregex.a
../strings/libmystrings.a -ldl -lnsl -lm -lz -lcrypt -lpthread
[sparc] make[4]: Leaving directory
`/usr/src/bs/BUILD/mysql-3.23.27-beta/sql'
[sparc] ./gen_lex_hash > lex_hash.h
[sparc] make[3]: [sparc] make[3]: Leaving directory
`/usr/src/bs/BUILD/mysql-3.23.27-beta/sql'
[sparc] make[2]: Leaving directory
`/usr/src/bs/BUILD/mysql-3.23.27-beta/sql'
[sparc] make[1]: Leaving directory `/usr/src/bs/BUILD/mysql-3.23.27-beta'
[sparc] *** [lex_hash.h] Error 138
[sparc] make[2]: *** [all-recursive] Error 1

Comment 1 Jakub Jelinek 2000-11-01 10:00:13 UTC
MySQL fault, should be fixed in mysql-3.23.27-2.


Note You need to log in before you can comment on or make changes to this bug.