Bug 20127 - Leaves orphan loopd and modprobe processes
Summary: Leaves orphan loopd and modprobe processes
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-31 23:19 UTC by Thornton Prime
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-16 17:41:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thornton Prime 2000-10-31 23:19:17 UTC
The following autofs configuration (mounting ISO images via loopback)
leaves orphan loopd processes and modprobe processes. They seem to be
growing and I suspect I will need to reboot my machine after a couple of
months.

# auto.master
/home/belvedere/CD-ROM  /etc/auto.d/cdrom       loop

# auto.d/cdrom
*       -fstype=auto    :/home/belvedere/Software/ISO/&

After 2 weeks of uptime, I have about 100 each of modprobe processes and
loopd processes. Most of he modprobe processes are marked status DN, and
most of the loopd processes are marked DWN. Each of the processes appears
to have active file handles.

Restarting autofs doesn't help since these processes appear orphaned.

Comment 1 Nalin Dahyabhai 2001-02-16 17:41:26 UTC
I think these are known bugs in previous versions of loopd.  Reassigning to
kernel.

Comment 2 Arjan van de Ven 2001-02-16 17:48:49 UTC
If this is the 2.2.16-22 kernel, known bug. Upgrade to the errate kernel 
which has the fix. I'm closing this bug as "fixed in errata".
If the errata kernel does not fix it for you, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.