Bug 201280 - unhandled exception during installation on x86_64
unhandled exception during installation on x86_64
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-03 19:23 EDT by Chris Ross
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 11:57:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ross 2006-08-03 19:23:53 EDT
Description of problem:

At the start of trying to install packages, just after formatting the various filesystems, I get an 
"unhandled exception" when python fails a os.fork() with "OSError: [Errno 12] Cannot allocate memory"

Version-Release number of selected component (if applicable):

RHEL4 Update 3 ES installation DVD (constructed from released CD images,which show the same error)

How reproducible:

2 for 2.


The full text of the exception is as follows.  transcribed by hand, but I hope it's correct:

Traceback (most recent call last):
  File "/usr/src/build/711710-x86_86/install//usr/lib/anaconda/gui.py", line 1074, in 
handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/src/build/711710-x86_86/install//usr/lib/anaconda/iw/progress_gui.py", line 242, in 
renderCallback
    self.intf.icw.nextClicked()
  File "/usr/src/build/711710-x86_86/install//usr/lib/anaconda/gui.py", line 789, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/src/build/711710-x86_86/install//usr/lib/anaconda/dispatch.py", line 171, in gotoNext
    self.moveStep()
  File "/usr/src/build/711710-x86_86/install//usr/lib/anaconda/dispatch.py", line 239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/src/build/711710-x86_86/install//usr/lib/anaconda/packages.py", line 967, in doInstall
    syslog.start(instPath, syslogname)
  File "/usr/src/build/711710-x86_86/install//usr/lib/anaconda/syslogd.py", line 65, in start
    self.pid = os.fork ()
OSError: [Errno 12] Cannot allocate memory
Comment 1 Jeremy Katz 2006-08-07 11:26:52 EDT
How much memory do you have?
Comment 2 Chris Ross 2006-08-07 12:28:21 EDT
4 GB.  2 GB per processor.
Comment 5 Tigran Zakoyan 2006-11-22 06:50:42 EST
have something very similar installing FC6 x86_64.

The installation sequence:

default (graphical) type of installation
skipping the media check
installation language russian
keyboard layout russian microsoft
partitioning - manually
3 existing partitions - hda1 51 Gb  for XP, hda2 2 Gp as swap, hda3 23 Gb Ubuntu
removed hda 3 and created a new one of 12 gb, primary, root
GRUB settings leaved as suggested - two bootable partitions, Fedora as default.
network settings - no DHCP, no IPv6, manual IP+GW+DNS
TZ - Moscow (as suggested)

Next, on the page of choosing tha package groups to be installed, after choosing
"Development tools" checkbox  I've clicked "Fedora Extras" and had exeption
(twice each time I've tried to install under same conditions)

Here is the traceback:

File "/usr/lib/anaconda/iw/netconfig_dialog.py", line 69, in _netdevChanged
if netdev.get("ipaddr"):
self.xml.get_widget("ipv4AddressEntry").set_text(netdev.get("ipaddr")
AttributeError: 'NoneType' object has no attribute 'set_text'

The hardware is
http://www.signalcomputer.it/prodotti/notebook/olidata_stainer-w2800.htm
with 1Gb of RAM instead of 512M
Comment 6 Chris Lumens 2006-11-22 09:46:52 EST
Tigran:  your issue is not related to this bug report, and is happening in
Fedora Core instead of in RHEL.  Please report different bugs on different bug
reports.  However, we already have your issue fixed.  See the bug
AnacondaExtrasConfig for a description of how to work around the problem.
Comment 7 David Cantrell 2007-03-15 14:41:14 EDT
Please attach /tmp/anaconda.log and /tmp/syslog to this bug report.  We need
more information to figure out how to debug this.
Comment 8 Red Hat Bugzilla 2007-06-11 23:13:45 EDT
requested by Jams Antill

Note You need to log in before you can comment on or make changes to this bug.