Bug 2012824 - qt6-qtbase missing on s390x
Summary: qt6-qtbase missing on s390x
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt6-qtbase
Version: 35
Hardware: s390x
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Grulich
QA Contact:
URL:
Whiteboard:
: 2016829 (view as bug list)
Depends On:
Blocks: ZedoraTracker F-ExcludeArch-s390x 2016808 2031792
TreeView+ depends on / blocked
 
Reported: 2021-10-11 11:39 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2022-03-14 21:00 UTC (History)
6 users (show)

Fixed In Version: qt6-qtbase-6.2.3-2.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-14 21:00:25 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Qt Bug Tracker QTBUG-93101 0 None None None 2021-10-11 11:39:58 UTC

Description Dominik 'Rathann' Mierzejewski 2021-10-11 11:39:59 UTC
Description of problem:
There's no qt6-qtbase build for s390x starting with qt6-qtbase-6.2.0~beta4-2.fc36.

Version-Release number of selected component (if applicable):
qt6-qtbase-6.2.0-1.fc36

How reproducible:
Always

Steps to Reproduce:
1. Try building mkvtoolnix in koji on s390x

Actual results:
DEBUG util.py:444:  No matching package to install: '/usr/bin/qmake6'
DEBUG util.py:444:  No matching package to install: 'cmake(Qt6Concurrent)'
DEBUG util.py:444:  No matching package to install: 'cmake(Qt6Core)'
DEBUG util.py:444:  No matching package to install: 'cmake(Qt6DBus)'
DEBUG util.py:444:  No matching package to install: 'cmake(Qt6Gui)'
DEBUG util.py:444:  No matching package to install: 'cmake(Qt6Network)'
DEBUG util.py:444:  No matching package to install: 'cmake(Qt6Widgets)'

Expected results:
Successful build like on other arches.

Additional info:
Looks like s390x builds were disabled Sep 13th in https://src.fedoraproject.org/rpms/qt6-qtbase/c/4d550dc675b1b517f785328705d26ddc15b47f03 without filing a bug in RH bugzilla.

Comment 1 Jan Grulich 2021-10-11 17:18:04 UTC
Hi, we disabled Qt6 on s390x, because qtdeclarative doesn't build there.

Qt issue: https://bugreports.qt.io/browse/QTBUG-93101

Comment 2 Davide Cavalca 2021-10-25 16:04:32 UTC
*** Bug 2016829 has been marked as a duplicate of this bug. ***

Comment 3 Dominik 'Rathann' Mierzejewski 2021-11-14 14:29:39 UTC
This is affecting F35 now. Looks like the bugs are in spirv-tools and glslang and proposed fixes have been submitted upstream.

Comment 4 Jan Grulich 2021-11-15 08:35:07 UTC
(In reply to Dominik 'Rathann' Mierzejewski from comment #3)
> This is affecting F35 now. Looks like the bugs are in spirv-tools and
> glslang and proposed fixes have been submitted upstream.

I'm aware of both upstream reviews, I'm just waiting for their approval and then we can try to backport those to Fedora and enable s390x again.

Comment 5 Jan Grulich 2021-11-15 08:35:58 UTC
For reference:

SPIRV-Tools PR: https://github.com/KhronosGroup/SPIRV-Tools/pull/4622
glslang PR: https://github.com/KhronosGroup/glslang/pull/2800

Comment 6 Dominik 'Rathann' Mierzejewski 2022-02-02 12:15:21 UTC
Looks like both PRs were merged. Can you ping Qt upstream?

Comment 7 Jan Grulich 2022-02-02 12:16:38 UTC
(In reply to Dominik 'Rathann' Mierzejewski from comment #6)
> Looks like both PRs were merged. Can you ping Qt upstream?

Both were merged, but SPIRV-tools fails to build because of GCC 12 and therefore we still don't have s390x builds.

Comment 8 Dominik 'Rathann' Mierzejewski 2022-02-16 12:23:53 UTC
spirv-tools was built successfully:
f36: https://koji.fedoraproject.org/koji/buildinfo?buildID=1918790
f37: https://koji.fedoraproject.org/koji/buildinfo?buildID=1918681

Is there anything else blocking this?

Comment 9 Fedora Update System 2022-03-06 14:28:18 UTC
FEDORA-2022-ab37e9cfe7 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-ab37e9cfe7

Comment 10 Fedora Update System 2022-03-06 17:01:42 UTC
FEDORA-2022-ab37e9cfe7 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-ab37e9cfe7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-ab37e9cfe7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2022-03-07 15:51:00 UTC
FEDORA-2022-ab37e9cfe7 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-ab37e9cfe7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-ab37e9cfe7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2022-03-14 21:00:25 UTC
FEDORA-2022-ab37e9cfe7 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.