Bug 201305 - Digital signature of files in openoffice.org not functioning
Digital signature of files in openoffice.org not functioning
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 210725 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 04:38 EDT by Giuseppe Castagno
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.0.4-2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-26 11:34:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB backtrace of OOo crash (9.23 KB, text/plain)
2006-08-05 07:13 EDT, Giuseppe Castagno
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 135137 None None None Never
OpenOffice.org 51931 None None None Never

  None (edit)
Description Giuseppe Castagno 2006-08-04 04:38:21 EDT
Description of problem:
Adding digital signature to OOo writer file is not possible, and file signed
with a working OOo installation (Windows) are not displayed as signed.

Version-Release number of selected component (if applicable):
[root@nbklx i386]# rpm -qa openoffice.org\*
openoffice.org-calc-2.0.2-5.17.2
openoffice.org-pyuno-2.0.2-5.17.2
openoffice.org-math-2.0.2-5.17.2
openoffice.org-core-2.0.2-5.17.2
openoffice.org-impress-2.0.2-5.17.2
openoffice.org-draw-2.0.2-5.17.2
openoffice.org-xsltfilter-2.0.2-5.17.2
openoffice.org-writer-2.0.2-5.17.2
openoffice.org-langpack-it-2.0.2-5.17.2
openoffice.org-graphicfilter-2.0.2-5.17.2
openoffice.org-testtools-2.0.2-5.17.2
openoffice.org-javafilter-2.0.2-5.17.2
openoffice.org-emailmerge-2.0.2-5.17.2
openoffice.org-base-2.0.2-5.17.2
[root@nbklx i386]#

And this as well, I think it's relevant:
[root@nbklx i386]# rpm -qa xmlsec1\*
xmlsec1-openssl-1.2.9-4.2
xmlsec1-nss-1.2.9-4.2
xmlsec1-devel-1.2.9-4.2
xmlsec1-openssl-devel-1.2.9-4.2
xmlsec1-nss-devel-1.2.9-4.2
xmlsec1-1.2.9-4.2
xmlsec1-debuginfo-1.2.9-4.2
[root@nbklx i386]#

How reproducible:
Always

Steps to Reproduce:
1. open a file with OOo writer;
2. using menu choose: File | Digital signatures... 
  
Actual results:
You are showed a warning dialog box with:

"Digital signatures functionality could not be used, because no
Mozilla user profile was found. Please check the Mozilla
installation."

Expected results:
A list of the signatures already in the file should be presented. It should be
empty if no signature is present.
From there the dialog to add signature to the OOo file can be carried on.

Additional info:
If you sign a file with OOo from OpenOffice.org (or in Windows) you won't see
the digital signature using FC5 OOo.

Deinstalling FC5 OOo and installing the OpenOffice.org original distro and with
that I was able to sign the file.

I did some debug using ooo-build infrastructure, and I can provie further info
(alas ! only few infos ), seems related to --with-system-xmlsec configure flag.

I added the OOo bug reference that drove me here.
Comment 1 Caolan McNamara 2006-08-04 08:49:25 EDT
well, level 1 of the problem is that the xmlsecurity stuff looks for the moz
address book stuff to get the bootstrap thing to find the profile location of
mozilla/firefox to find the cert directory. 

With a system-mozilla build this is disabled because of the dread
http://bugzilla.mozilla.org/show_bug.cgi?id=135137

setting the environmental variable MOZILLA_CERTIFICATE_FOLDER to the appropiate
location might work around. I'll see if I can hack up the tiniest mozilla
profile bootstrap finder part of the mozab to support this just working out of
the box
Comment 2 Giuseppe Castagno 2006-08-04 08:59:14 EDT
I did some dev grunt work, described in short here:

http://lists.ximian.com/pipermail/openoffice/2006-August/001953.html

Can it help ?
Comment 3 Giuseppe Castagno 2006-08-04 09:06:58 EDT
I forgot to mention that I have MOZILLA_CERTIFICATE_FOLDER pointing to the right
folder.
According to what I read here:
http://wiki.services.openoffice.org/wiki/How_to_use_digital_Signatures
Comment 4 Caolan McNamara 2006-08-04 11:22:11 EDT
Damnit, it's almost certainly 
PKGCONFIG_MODULES=xmlsec1
->
PKGCONFIG_MODULES=xmlsec1-nss

which causes the problem. Doing that allows me to see the dialog at least
Comment 5 Giuseppe Castagno 2006-08-05 07:09:49 EDT
I rebuild m180 from scratch, with the suggestion in comment #4 and it appears
the fix's only partial.

Now I can see the signatures on a signed OOo file, but when I try to add a new
signature it crashes.

Behaviour to crash it:

File | Digital signatures...
(the dialog listing the current signature on the file opens)
click Add.. 
The dialog to select a certificate opens, select a certificate, when you click
OK to add it OOo crashes.

I'm going to attach a GDB backtrace of the crash, hoping it will be usefull.
Comment 6 Giuseppe Castagno 2006-08-05 07:13:41 EDT
Created attachment 133677 [details]
GDB backtrace of OOo crash
Comment 7 Caolan McNamara 2006-08-06 13:47:22 EDT
Hard to check that without an actual certificate, at the moment
Comment 8 Giuseppe Castagno 2006-08-06 15:06:25 EDT
I have a 30 day certificate ( PersonalSign Demo ) generated free here:

http://www.globalsign.net/digital_certificate/personalsign/index.cfm


I've collected information on how to generate one on your own. Let me know if
you need them.
Comment 9 Caolan McNamara 2006-08-09 05:18:35 EDT
yeah, part 2 reproducable now
Comment 10 Caolan McNamara 2006-08-10 09:57:28 EDT
bugger it anyway, looks like only using the internal hacked up libxmlsec will
work. Will include that back into FC-6
Comment 11 Caolan McNamara 2006-08-26 11:34:44 EDT
Back in FC-6/rawhide now as openoffice.org 2.0.4-2.1, crashfix will be in the
next FC-5 update if there is one, but functionality won't return in FC-5 :-(
Comment 12 Caolan McNamara 2006-10-16 04:52:53 EDT
*** Bug 210725 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.