Bug 201306 - tinyerp dependency error on install
tinyerp dependency error on install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tinyerp (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 04:55 EDT by Mr. Mizzen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 10:14:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mr. Mizzen 2006-08-04 04:55:27 EDT
Description of problem:
Can not install


Version-Release number of selected component (if applicable):
3.3.0-1.fc5
3.3.0-2.fc5

How reproducible:
Very


Steps to Reproduce:
1. Use yum or pkg installer to install tinyerp client / server
2. Dependency failure message
3.
  
Actual results:
Never installs due to dependency issue

Expected results:
Install with no errors

Additional info:

The actual dependency message is:
Missing Dependency: python < 0:2.4 is needed by package python-reportlab

Fedora Core installs with python-2.4.2-3.2.1.i386.rpm (before any updates)
If I read the above correctly, tinyerp want a python package older than 0:2.4
and FC5 ships with 0:2.4.2 and now updated to 0:2.4.3
Comment 1 Dan Horák 2006-08-04 10:14:13 EDT
This is not a problem of the tinyerp package, it only depends on python(abi) =
2.4 and unversioned python-reportlab package. It look like a problem of
python-reportlab package in Extras, but as I looked into the current sources of
python-reportlab there is not dependency on python < 2.4 either. What versions
of python-* packages do you have and what repositories do you use? I think that
I have seen such problem with python-reportlab installed from some other repository.
Comment 2 Mr. Mizzen 2006-08-05 05:26:45 EDT
Dan,

Fastest bug report reply ever. Many thanks for the fast response!

Your questions first:
The only repositories I use are Fedora and Livna.
The one python package livna offers is not installed.
List of python-* packages
Installed Packages
python.i386                              2.4.3-8.FC5            installed
python-devel.i386                        2.4.3-8.FC5            installed
python-docs.noarch                       2.4.3-0.9.FC5          installed
python-elementtree.i386                  1.2.6-4.2.1            installed
python-kid.noarch                        0.9.3-1.fc5            installed
python-ldap.i386                         2.0.6-5.2.1            installed
python-numeric.i386                      23.7-2.2.1             installed
python-pyblock.i386                      0.15-1                 installed
python-sqlite.i386                       1.1.7-1.2              installed
python-tools.i386                        2.4.3-8.FC5            installed
python-urlgrabber.noarch                 2.9.8-2                installed

You are correct that the problem is NOT with tinyerp. tinyerp only triggers the
problem.

python-reportlab is the root of the error as shown below:
yum install python-reportlab
...........................................
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package python-reportlab.i386 0:1.19-2 set to be updated
--> Running transaction check
--> Processing Dependency: python < 0:2.4 for package: python-reportlab
--> Finished Dependency Resolution
Error: Missing Dependency: python < 0:2.4 is needed by package python-reportlab

Extras has these listings:
python-reportlab.i386                    1.19-2                 extras
python-reportlab.noarch                  1.20-5.fc5             extras
When using yum, it tries to install the first one, and that fails.

To force the higher version to install, I tried the following and it did install:
yum install python-reportlab.noarch
I think the true problem is in how yum resolves package names - or - just the
fact the reportlab package name extension was changed. Someone just needs to
remove the older version from extras as it will not work with fc5. fc5 ships
with python > 2.4

After that was installed, tinyerp and tinyerp-server both installed without error.


However, when trying the demo or admin accounts, tinyerp simply reports:
Connection error !
Unable to connect to the server !

Other than buying the manual, do you have any suggestions or a list of "simple"
steps to get the demo running?


Thanks,


Note You need to log in before you can comment on or make changes to this bug.