Bug 201309 - Update Gettext tools to 0.15
Update Gettext tools to 0.15
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 05:13 EDT by Dwayne Bailey
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-26 23:01:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dwayne Bailey 2006-08-04 05:13:02 EDT
Description of problem:
The current release of FC5 does not contain the latest Gettext tools.  The main
advantage for a localiser is that these tools introduce massivce performance
improvements in merging messages using msgmerge.

Version-Release number of selected component (if applicable):
Currently on FC5 0.14.5
Lastest Gettext release 0.15

Additional info:
Other features such as msgctxt addition for context information are more long
term in nature and will slowly filter into projects.  But the immediate benefit
to a localiser with the performance improvement is great indeed.
Comment 1 Jens Petersen 2006-08-04 07:24:59 EDT
Are there any compatibility problems with 0.14.x?

I looked at the NEWS file and wondered about:

* libgettextpo library:
  - The error handler type passed to po_file_read(), po_file_write(),
    po_message_check_format() has changed.
    This is an incompatible change: Programs using the library *must* update
    their code.
    Binary compatibility is guaranteed, however.

* The 'mkinstalldirs' shell script is no longer needed and no longer installed
  by gettextize.
Comment 2 Dwayne Bailey 2006-08-05 03:35:52 EDT
Apart from those mentioned in comment 1 which might affect other programs.  I am
aware of only one that may affect existing PO files being checked with msgfmt -c
(The PO files themselves should still howver be usable).  The issue is that
msgfmt now does stricter checking on plural message translations ensuring that
all variables are correctly included.
Comment 3 Jens Petersen 2006-08-07 04:55:34 EDT
Okay, I think it is too late now for fc6 to upgrade to 0.15 so I'm going to
update to 0.14.6 for FC6 and  0.15 will go into FC7.

I put a test srpm of gettext-0.15 at:
http://people.redhat.com/petersen/gettext-0.15-0.src.rpm
if it helps.
Comment 4 Jens Petersen 2006-10-26 23:01:20 EDT
I built gettext-0.15-1.fc7 for rawhide.

Note You need to log in before you can comment on or make changes to this bug.