Bug 2013148 - All critical alerts shipped by CMO should have links to a runbook
Summary: All critical alerts shipped by CMO should have links to a runbook
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.9
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.9.z
Assignee: Brad Ison
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 2014512 (view as bug list)
Depends On: 2000490
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-12 08:45 UTC by Philip Gough
Modified: 2021-10-26 17:23 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2000490
Environment:
Last Closed: 2021-10-26 17:22:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 1435 0 None open Bug 2013148: jsonnet: Drop unnecessary kube-state-metrics alerts 2021-10-18 07:54:09 UTC
Red Hat Product Errata RHBA-2021:3935 0 None None None 2021-10-26 17:23:04 UTC

Comment 2 Simon Pasquier 2021-10-15 12:58:45 UTC
*** Bug 2014512 has been marked as a duplicate of this bug. ***

Comment 3 Junqi Zhao 2021-10-18 11:21:34 UTC
tested with the PR, "KubeStateMetricsShardingMismatch|KubeStateMetricsShardsMissing" alerts are removed, other critical alerts shipped by CMO have runbook_url field
# oc -n openshift-monitoring get prometheusrule kube-state-metrics-rules -oyaml|grep -E "KubeStateMetricsShardingMismatch|KubeStateMetricsShardsMissing"
no result

Comment 8 errata-xmlrpc 2021-10-26 17:22:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.4 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3935


Note You need to log in before you can comment on or make changes to this bug.