Bug 201323 - Yum exit with 'Error parsing baseurl'
Yum exit with 'Error parsing baseurl'
Status: CLOSED DUPLICATE of bug 212180
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 08:20 EDT by Mykola Ulianytskyi
Modified: 2014-01-21 17:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-29 12:02:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mykola Ulianytskyi 2006-08-04 08:20:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.8.0.5) Gecko/20060801 Fedora/1.5.0.5-7 Firefox/1.5.0.5 pango-text

Description of problem:
yum will not work if you have space symbol in baseurl

Sample: 
baseurl=file:///media/Fedora Core 6/RPMS/

If we replace ' ' to '%20' yum start to execute 'list' command but 'yum install some_package' failed with 'Error Downloading Packages: package_name: failure ... [Errno 256] No more mirrors to try' 

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
Insert space symbol in baseurl

Actual Results:


Expected Results:


Additional info:
Comment 1 Jeremy Katz 2006-08-07 11:12:34 EDT
Does it work if you quote it?  spaces can be used for separating args, so alone
there really isn't a way for them to work
Comment 2 Mykola Ulianytskyi 2006-08-07 11:26:17 EDT
> Does it work if you quote it? 
no
Comment 3 Julian Sikorski 2006-10-31 10:46:18 EST
The issue is iirc not really caused by spaces in baseurl, but by media:/// entry
in DVD repodata.
Comment 4 Aleksandar Milivojevic 2006-11-29 11:34:11 EST
I've run into the same problem with RHEL5 beta 2.  It's the media:/// stuff in
DVD repodata:

Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for kernel-xen to pack into transaction set.
media://1163271601.930360%231/kernel-xen-2.6.18-1.2747.el5.x86_64.rpm: [Errno 4]
IOError: <urlopen error unknown url type: media>
Trying other mirror.
Error: failed to retrieve kernel-xen-2.6.18-1.2747.el5.x86_64.rpm from
rhel5b2-media-client
error was [Errno 4] IOError: <urlopen error unknown url type: media>

I don't remember having this problem with CentOS4 (RHEL4 clone) and yum that
came with it (ver. 2.4.x).  Maybe you could borrow some code back ;-)

Workaround is to copy installation media onto disk (if there's enough space) and
rebuild repodata stuff (using createrepo command), than point yum to on-disk
copy.  Tested on RHEL5 beta 2, works.  Downside is that it will waste couple of
gigs of disk space.  Upside is that you don't need to dig for that installation
media anymore ;-)
Comment 5 Jeremy Katz 2006-11-29 12:02:50 EST

*** This bug has been marked as a duplicate of 212180 ***

*** This bug has been marked as a duplicate of 212180 ***

Note You need to log in before you can comment on or make changes to this bug.