Bug 201344 - GDM shouldn't enable entry field if the Smart Card is required.
GDM shouldn't enable entry field if the Smart Card is required.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gdm (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 202140 (view as bug list)
Depends On:
Blocks: 181386 181509
  Show dependency treegraph
 
Reported: 2006-08-04 11:12 EDT by Bob Relyea
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 00:50:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Relyea 2006-08-04 11:12:16 EDT
Description of problem:

GDM shouldn't allow any input if require smartcard is set.

Version-Release number of selected component (if applicable):

FC6 Test2/devel

How reproducible:

Set smart card login require to true
Try run gdm.
Try to enter a user name
  
Actual results:

You can enter a name.

Expected results:

No input should be accepted.
Comment 1 Ray Strode [halfline] 2006-08-10 20:47:52 EDT
*** Bug 202140 has been marked as a duplicate of this bug. ***
Comment 6 Ray Strode [halfline] 2006-10-12 20:59:22 EDT
shoudl be fixed in 

gdm-2.16.0-15.el5
Comment 7 Orla Hegarty 2006-10-13 13:50:38 EDT
Testing candidate 20061006.2 I was about to re-open the bug due to one boundary
case not being taken care off. Then I checked my gm version.

$ rpm -qa | grep gdm
gdm-2.16.0-14.el5

So not -15 perhaps my boundary case is taken care of in that version. So I am
going to hold off re-opening until I re-test with -15

Steps to Reproduce:
1. Configure smart card login to require smart cards
2. At the gdm login prompt after
2.a A Reboot or
2.b A logout from the previous session by removing the smart card
The UI presented is 

A text box with ... in it. Above the text box is Username. Below the text box is
Please insert your smart card. 

You cannot type in the box. Good 

However, Boundary case
3. Logout from the previous session with the card inserted
4. When the UI is presented to enter the pin for the named smart card, remove
the smart card

5. New UI is presented ....

A text box with nothing in it. Above the text box is, nothing, no text label
Below the text box is Please insert your smart card. 

You can type in the text box - not good. 
Comment 12 RHEL Product and Program Management 2006-11-20 16:23:41 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 13 Chandrasekar Kannan 2006-11-21 13:17:29 EST
per bug council on 11/17,

this is a rhel5 blocker.
Comment 17 Chandrasekar Kannan 2006-12-20 20:03:10 EST
with rhel5-rc-snapshot#5

 not able to reproduce comment #0
 not able to reproduce comment #3
 not able to reproduce comment #7
Comment 18 Ray Strode [halfline] 2006-12-21 00:50:13 EST
I haven't been able to reproduce either.  Given that it's not readily
reproducible, this isn't really as severe as I thought it was.  I don't think
this should really be a blocker at this point.

(if it were readily reproducible, then customers would be much more likely to
hit it and it would be a much more severe problem). 

devnacking.

Note You need to log in before you can comment on or make changes to this bug.