This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 201345 - GDM repeatedly tries to restart itself.
GDM repeatedly tries to restart itself.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gdm (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 202265 (view as bug list)
Depends On:
Blocks: 181386 181509 203411
  Show dependency treegraph
 
Reported: 2006-08-04 11:16 EDT by Bob Relyea
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 13:20:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Relyea 2006-08-04 11:16:25 EDT
Description of problem:

Sometimes, after enabling smart card login, GDM will forget that it's already
running, or that the user is already logged in, and try to continually restart
itself.

Version-Release number of selected component (if applicable):
 devel, fc6 test 2.

How reproducible:

Hard to reproduce. I have only seen this on a fresh install when enabling
smartcard login.


Additional info on how to reproduce would be helpful.
Comment 1 Ray Strode [halfline] 2006-08-11 17:08:54 EDT
*** Bug 202265 has been marked as a duplicate of this bug. ***
Comment 2 Ray Strode [halfline] 2006-08-11 17:09:38 EDT
Hi Bob L.,

do you have any idea what triggers the bug?
Comment 3 Bob Lord 2006-08-11 17:33:02 EDT
(In reply to comment #2)
> Hi Bob L.,
> 
> do you have any idea what triggers the bug?

With only two manifestations of this problem, I'm sad to report I don't have
much to go on.

I'm a magnet for bugs like this, so I'll keep an eye out for clues the next time
this happens. 
Comment 9 Bob Relyea 2006-08-21 16:08:52 EDT
The x86_64 version of thie problem appears to be a pam issue. The above crash is
from sudo.

bob
Comment 10 Bob Relyea 2006-08-21 20:58:46 EDT
Bugzilla Bug 203411 "pam_pkcs11 (and thus all login apps) crash when Smart Card
login is turned on (64 bit)" has been created to handle the continuing crashing
issue on x86_64. This bug can return to "gdm decides to suddenly startup on it's
own".

Unfortunately it's also back to 'hard to reproduce' as well.

bob
Comment 12 RHEL Product and Program Management 2006-11-20 16:23:01 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 13 Chandrasekar Kannan 2006-11-21 13:20:34 EST
per bug council on 11/17,

team agreed that this bug is not reproducible anymore. 

Note You need to log in before you can comment on or make changes to this bug.