Bug 20136 - Mikmod package breaks compiling/linking
Mikmod package breaks compiling/linking
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mikmod (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-01 01:59 EST by Stan Bubrouski
Modified: 2014-03-16 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-01 01:59:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stan Bubrouski 2000-11-01 01:59:19 EST
There is a typo somewhere in the mikmod which results in a broken
/usr/bin/libmikmod-config script:

                echo $libdir -lmikmod -lpthread -ldl -L%prefix/lib 
-L/usr/lib  -lm

The %prefix breaks makefiles which include it because it cannot be
expanded.  The %prefix should in fact be ${prefix} not %prefix.  Not sure
where in the source this problem occurs but it causes annoying warnings
when compiling apps which use it.  For example:

/bin/sh ../../libtool --mode=link gcc  -O2 -march=i386 -mcpu=i686 -Wall
                -fomit-frame-pointer -funroll-all-loops -finline-functions
-ffast-math
                -m486  -o libmikmod.la -rpath /usr/lib/xmms/Input -module
-avoid-version
                drv_xmms.lo plugin.lo -L/usr/lib -L/usr/X11R6/lib -lgtk
-lgdk -rdynamic
                -lgmodule -lgthread -lglib -lpthread -ldl -lXi -lXext -lX11
-lm -lpthread
                -L/usr/lib -lmikmod -lpthread -ldl -L%prefix/lib -L/usr/lib
-lm 
                ../../libtool: cd: %prefix/lib: No such file or directory
                libtool: link: warning: cannot determine absolute directory
name of
                `%prefix/lib'
                libtool: link: passing it literally to the linker, although
it might fail

see the problem? Any input?

-Stan Bubrouski
Comment 1 Bill Nottingham 2001-01-18 13:21:41 EST
This appears to be fixed in the current package (my /usr/bin/libmikmod-config
is OK.)

This is somewhat odd, in that I don't recall fixing it. :)
Comment 2 Stan Bubrouski 2001-01-18 17:10:56 EST
Yeah now it says echo $libdir -lmikmod -lpthread -ldl -L${prefix}/lib
-L/usr/lib  -lm


so at some point it seems to have gotten fixed.

Note You need to log in before you can comment on or make changes to this bug.