Bug 201361 - installer needs raid 6 support, at least for pre-existing raid 6 in kickstart
installer needs raid 6 support, at least for pre-existing raid 6 in kickstart
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 12:27 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 11:30:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-08-04 12:27:43 EDT
Description of problem:
I upgraded my raid 5 physical volumes to raid 6.  They contain non-essential
filesystems that I could configure post install, but ideally the installer
should not simply discard them and then complain that it can't bring up the
volume group that contains them, so it can't set up the filesystems in them.

Version-Release number of selected component (if applicable):
anaconda-11.1.0.77-1

How reproducible:
Every time

Steps to Reproduce:
1.Create a raid 6 device
2.Start the installer
  
Actual results:
It logs on VT3 that it doesn't support raid 6 and ignores the device, so volume
groups containing them can't be brought up

Expected results:
Even if it does not support raid 6 in the GUI, it should be able to trivially
support the reuse of such devices in existing volume groups, since it doesn't
even have to deal with them other than bringing them up.

Additional info:
Comment 1 Jeremy Katz 2006-08-07 11:30:15 EDT
anaconda supports raid6, but the module name changed so we didn't load it and
then notice so don't support raid6 :)

Adjusted the module list

Note You need to log in before you can comment on or make changes to this bug.