Bug 201378 - pinfo has troubles with Unicode in man pages
pinfo has troubles with Unicode in man pages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pinfo (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 14:21 EDT by Radek Bíba
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 02:14:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2006-08-04 14:21:05 EDT
Description of problem:
SSIA

Version-Release number of selected component (if applicable):
pinfo-0.6.8-11.2.1

How reproducible:
Always

Steps to Reproduce:
1. e.g. LC_ALL=ru_RU.utf8 pinfo -m rpm
(or even `pinfo -m head' in English because it contains apostrophes)
  
Actual results:
Garbage instead of almost all characters.
(or instead of the apostrophes)

Expected results:
Preserved Unicode, see LC_ALL=ru_RU.utf8 man rpm
(or apostrophes, see man head)
Comment 1 Miroslav Lichvar 2006-09-15 02:14:04 EDT
This is fixed in new upstream release 0.6.9. pinfo-0.6.9-1.fc5 in updates.
Comment 2 Radek Bíba 2006-09-15 04:06:45 EDT
Awesome, Miroslav. Thanks!

Note You need to log in before you can comment on or make changes to this bug.