Bug 2013861 - All the config files and directories in /etc are missing and stuff in /usr/share is marked as %config
Summary: All the config files and directories in /etc are missing and stuff in /usr/sh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wireplumber
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact:
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F35FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-10-13 22:32 UTC by Neal Gompa
Modified: 2021-10-28 18:27 UTC (History)
4 users (show)

Fixed In Version: wireplumber-0.4.3-3.fc35 wireplumber-0.4.4-2.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-16 01:14:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Neal Gompa 2021-10-13 22:32:00 UTC
Description of problem:
Apparently with wireplumber-0.4.2-1.fc35, all the files moved from /etc to /usr/share without leaving behind a configuration skeleton in /etc and all the files in /usr/share are marked as config files incorrectly.

Version-Release number of selected component (if applicable):
0.4.3-2.fc35

How reproducible:
Always

Comment 1 Fedora Blocker Bugs Application 2021-10-13 22:32:58 UTC
Proposed as a Freeze Exception for 35-final by Fedora user ngompa using the blocker tracking app because:

 Releasing WirePlumber with a broken package setup in GA would be *really bad* for longer term maintenance of the package and dealing with user issues.

Comment 2 Neal Gompa 2021-10-13 22:43:56 UTC
I've made a fix for this in Rawhide, and I can merge this back into F35 easily enough: https://src.fedoraproject.org/rpms/wireplumber/c/8b2720bb79865ffac011653956a9e715b95a2fa1?branch=rawhide

Comment 3 Adam Williamson 2021-10-14 23:41:24 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/545 , marking accepted.

Comment 4 Fedora Update System 2021-10-15 02:07:20 UTC
FEDORA-2021-ed5693a16c has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-ed5693a16c

Comment 5 Fedora Update System 2021-10-15 02:07:22 UTC
FEDORA-2021-ed5693a16c has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-ed5693a16c

Comment 6 Fedora Update System 2021-10-15 14:49:37 UTC
FEDORA-2021-3c4c454c98 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-3c4c454c98

Comment 7 Fedora Update System 2021-10-15 20:52:04 UTC
FEDORA-2021-3c4c454c98 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-3c4c454c98`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-3c4c454c98

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2021-10-16 01:14:41 UTC
FEDORA-2021-ed5693a16c has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2021-10-24 20:21:28 UTC
FEDORA-2021-3c4c454c98 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-3c4c454c98

Comment 10 Fedora Update System 2021-10-28 18:27:37 UTC
FEDORA-2021-3c4c454c98 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.