Bug 201393 - better yum locking error message
better yum locking error message
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-08-04 15:41 EDT by Need Real Name
Modified: 2014-01-21 17:54 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 14:17:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-08-04 15:41:42 EDT
If root runs yum upgrade while the yum auto-updater is running, a message about
"yum already running" is displayed, which is good.

It would be even better if the message says what the other thing running was,
since the message is quite baffling at first.
Comment 1 Seth Vidal 2006-08-19 15:42:58 EDT
but we don't know what the other thing is. It's not reported.

suggestions on less confusing error messages?
Comment 2 Need Real Name 2006-08-19 17:28:11 EDT
Can the other thing be reported in the lockfile?
Comment 3 Jeremy Katz 2007-04-25 14:17:13 EDT
We can report the pid, but not much more.  Added pid reporting in CVS

Note You need to log in before you can comment on or make changes to this bug.