Bug 201409 - Cannot resize an table's width from dialog when set as automatic
Cannot resize an table's width from dialog when set as automatic
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 17:34 EDT by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 09:35:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2006-08-04 17:34:03 EDT
Description of problem:
I have defined a table and using the Table menu entry, resize the columns.
Pressing return acts as cancel instead of OK

Version-Release number of selected component (if applicable):
oowriter 2.0.3-7.7

How reproducible:
Always

Steps to Reproduce:
1. Create a 2 column table
2. Place the carat inside of the window and right click (produces a menu)
3. Select table. Resize the table and press return
  
Actual results:
Despite OK having focus, it actually cancels the change

Expected results:
The resize occurs

Additional info:
Comment 1 Caolan McNamara 2006-08-08 09:16:19 EDT
I can't reproduce a problem here, can you give me the exact steps, here's what I
did...

1. insert->table->ok (gives default 2x2 table)
2. click in e.g. last cell on first row
3. right click, select table
4. go to columns tab on this tabpage dialog
5. use the spinner to increase the width of column 1, (column 2 reduces
   automatically to fit)
6. press return

but the columns did indeed change dimensions as I expected. 
Comment 2 Paul F. Johnson 2006-08-08 09:19:12 EDT
Alter column 2 (make it smaller) and press return - the table doesn't resize
Comment 3 Caolan McNamara 2006-08-08 09:35:09 EDT
Perhaps we are seeing the same thing, the table does not shrink by default. 
The column does, but the other columns grow to fit. To resize the entire table
unclick automatic on the "table" tab, and select e.g. left; that allows the
table to change size.

So to change the entire table width, enter the desired size there in the table
tag. Or alternatively, or to modify individual columns, go to the columns tab
and click "adapt table width" which is now available for selection, and when
that's selected and you reduce e.g. column two's width then column one's width
doesn't grow to eat up the "automatic" width

If you use the mouse to drag the column boundaries around and then revisit the
dialog, the mode has been changed from "automatic" to "manual" silently to
enable the drags to achieve something

Note You need to log in before you can comment on or make changes to this bug.