Bug 2014332 - [scale] [4.8z] failed to get pod annotation: timed out waiting for annotations
Summary: [scale] [4.8z] failed to get pod annotation: timed out waiting for annotations
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.7
Hardware: All
OS: All
high
medium
Target Milestone: ---
: 4.8.z
Assignee: Tim Rozet
QA Contact: Anurag saxena
URL:
Whiteboard: perfscale-ovn
Depends On: 1997072
Blocks: 2014360
TreeView+ depends on / blocked
 
Reported: 2021-10-15 00:57 UTC by Tim Rozet
Modified: 2021-12-20 17:26 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1997072
: 2014360 (view as bug list)
Environment:
Last Closed: 2021-11-16 21:22:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ovn-kubernetes pull 798 0 None open Bug 2014332: [4.8z] Scale fixes for pods/exgws 2021-10-15 02:35:21 UTC
Red Hat Product Errata RHBA-2021:4574 0 None None None 2021-11-16 21:23:07 UTC

Comment 3 Mike Fiedler 2021-10-19 21:57:45 UTC
Failed verification on a cluster-bot cluster built from this PR (similar to the 4.9 bug 1997072 - see that bz for must-gather).

Cluster was a 120 node OVN cluster on AWS and the workload was node-density light.   Many FailedCreatePodSandBox events with reason "timed out waiting for annotations" are seen and pods take a long time for all to go Running.

On 4.10 latest nightly, the issue can not be reproduced - no annotation timeout events for node-density light in the same cluster configuration

Comment 7 Mike Fiedler 2021-11-04 18:35:12 UTC
Verified on 4.8 cluster-bot cluster build from openshift ovn-kubernetes pull 798 using the workload from comment 6 on a 120 node AWS cluster.  No annotation timeouts were seen.   Also regression tested on a small bare metal cluster

Comment 13 errata-xmlrpc 2021-11-16 21:22:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.20 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4574


Note You need to log in before you can comment on or make changes to this bug.