Bug 201447 - [x86_64] bad mask applied to graphics
Summary: [x86_64] bad mask applied to graphics
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-05 14:22 UTC by Paul F. Johnson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.0.4-2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-26 15:42:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OOo writer file demonstrating the problem (11.04 KB, application/vnd.oasis.opendocument.text)
2006-08-05 14:22 UTC, Paul F. Johnson
no flags Details
Image file used (3.33 KB, image/png)
2006-08-05 14:23 UTC, Paul F. Johnson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 68339 None None None Never

Description Paul F. Johnson 2006-08-05 14:22:24 UTC
Description of problem:
OOo writer is adding a black line and yellow line on the left hand side of a
frame to some images loaded into a document. The line is not there if the image
file is loaded into Gimp

Version-Release number of selected component (if applicable):
OOo writer 2.0.3-7.7

How reproducible:
Always

Steps to Reproduce:
1. Start a new document, insert the file attached to this report
2. Load the actual image into Gimp
3.
  
Actual results:
A black and yellow line can be seen in the OO doc

Expected results:
The image in OO writer should be the same as in Gimp

Additional info:
I've attached an OO document which demonstrates this problem as well as the
source graphic

Comment 1 Paul F. Johnson 2006-08-05 14:22:24 UTC
Created attachment 133683 [details]
OOo writer file demonstrating the problem

Comment 2 Paul F. Johnson 2006-08-05 14:23:04 UTC
Created attachment 133684 [details]
Image file used

Comment 3 Caolan McNamara 2006-08-07 13:26:30 UTC
reproduced, x86_64 only though

Comment 4 Caolan McNamara 2006-08-08 13:17:46 UTC
That's going to be a killer to track down, got to be a long/sal_Int32 problem
somewhere on the bitmap drawing code

Comment 5 Caolan McNamara 2006-08-10 12:06:56 UTC
figured it out, will be in next respin

Comment 6 Paul F. Johnson 2006-08-14 10:30:45 UTC
Any eta on this? I have some docs on the 64 bit box that needs to be sent
elsewhere and I can't because of this problem.


Note You need to log in before you can comment on or make changes to this bug.