Bug 2014514 - Checksum for fedora-cisco-openh264 is incorrect
Summary: Checksum for fedora-cisco-openh264 is incorrect
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openh264
Version: 35
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 2008803
TreeView+ depends on / blocked
 
Reported: 2021-10-15 12:57 UTC by Yosuke Matsumura
Modified: 2021-10-17 09:21 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-10-16 09:29:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Yosuke Matsumura 2021-10-15 12:57:47 UTC
Description of problem:
Getting the following checksum error during dnf and rpm-ostree upgrade:

Errors during downloading metadata for repository 'fedora-cisco-openh264':
  - Downloading successful, but checksum doesn't match. 
Calculated: 88b343b2fa5fc11878d2741c909948efba1c697ed9fe8571325839ebceb6a2ee1f6a10e68898bf30cea6d11c1507c267f2e0dfb83ab7d4da03f74246d8012434(sha512)  
Expected: 6635b9b103011623cf2fb065f7c3810195b487511215fa802e21dcb72cc1e8644166e8339284ef38d0516f8650527caca77f9194aeed92b414a94a816948d46e(sha512) 


Version-Release number of selected component (if applicable):
Fedora 35

How reproducible:
Every time

Steps to Reproduce:
1. Enable fedora-cisco-openh264 in /etc/yum.repos.d/fedora-cisco-openh264.repo
2. Try `dnf upgrade` or `rpm-ostree install gstreamer1-plugin-openh264`
3.

Actual results:
Shows errors in checksum. `dnf upgrade` will continue, but `rpm-ostree upgrade` will fail and quit.

Expected results:
No checksum error.

Additional info:
Manually checking the file `https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-35&arch=x86_64`, it appears that the checksums within do not match sha512sum of https://codecs.fedoraproject.org//openh264/35/x86_64/os/repodata/repomd.xml. 

Quickly checking the aarch64 files, and seems those are mismatched as well. Did not check other architectures. Fedora 34 does not have this issue.

Comment 1 Kalev Lember 2021-10-15 13:29:27 UTC
Mohan, can you take a look at this please? Looks like something went wrong when uploading the new versions.

Comment 2 1germes 2021-10-16 05:58:38 UTC
Having the same issue after Fedora 34 to 35 upgrade

Comment 3 Adrian Reber 2021-10-16 09:29:34 UTC
Should be fixed now. There is a bug in one of the tools creating this. The bug is fixed but not yet deployed because of the current infrastructure freeze.

Comment 4 1germes 2021-10-16 11:16:16 UTC
> Should be fixed now. There is a bug in one of the tools creating this. The bug is fixed but not yet deployed because of the current infrastructure freeze.

Yes, it is fixed now! Thanks

Comment 5 pragalakis 2021-10-17 09:21:36 UTC
This is also happening on fedora 33 to 34 upgrade


Note You need to log in before you can comment on or make changes to this bug.