Bug 201473 - All programs/windows are placed in Current Workspace
Summary: All programs/windows are placed in Current Workspace
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Blocker
TreeView+ depends on / blocked
 
Reported: 2006-08-05 23:26 UTC by Paul Dickson
Modified: 2014-06-18 09:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-13 04:03:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Dickson 2006-08-05 23:26:11 UTC
Description of problem:
When starting a Gnome session from gdm, all terminal windows and other programs
 are placed in the current workspace (you can flip workspaces while the session
is starting and leave programs in the then current workspace).

Version-Release number of selected component (if applicable):
gnome-session-2.15.90-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. Login to Gnome from GDM.
2.
3.
  
Actual results:
All windows appear in the current workspace.

Expected results:
Windows open in their saved workspace.

Additional info:
Reverting back to gnome-session-2.15.4-2 resolves the problem.

Comment 1 Matthias Clasen 2006-08-06 14:50:43 UTC
I bet this was broken by Soerens change to run the wm outside the session.

Comment 2 Ray Strode [halfline] 2006-08-09 19:01:07 UTC
yea probably.  So I think gnome-session has some hacks in it now to launch
compiz or metacity before starting the session.

That should be taken out, and instead, Soeren's wm switcher capplet should blow
away ~/.gnome2/session (after warning the user!) when switching wm's.

Comment 3 Ray Strode [halfline] 2006-08-12 05:16:17 UTC
can you report whether this is fixed in rawhide?  I pushed some changes that
should resovle this i think.

Comment 4 Paul Dickson 2006-08-13 03:26:21 UTC
It's fixed with gnome-session-2.15.90-3.fc6.

Comment 5 Ray Strode [halfline] 2006-08-13 04:03:58 UTC
great.  It looks like my changes caused other problems (see bug 202312), but
those should be resolved, too, by tomorrow.


Note You need to log in before you can comment on or make changes to this bug.